Bug 68898 - Add ability to bring up network interface on CD-ROM kickstart install
Add ability to bring up network interface on CD-ROM kickstart install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-15 16:01 EDT by Phil D'Amore
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-03 10:37:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil D'Amore 2002-07-15 16:01:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020524

Description of problem:
Currently, when a kickstart install is performed using a CD-ROM, the network
interface is not brought up.  This is somewhat inconvenient during the %post
portion of the install when extra packages, etc. need to be installed.  We
currently use a work-around to deal with this, but it would be nice to have an
option in the ks.cfg file to make this happen, at least for eth0, especially
since our workaround does not work for interfaces where BOOTPROTO=dhcp.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
kickstart a system from cd-rom.  The network interfaces are not brought up.

Additional info:
Comment 1 Jeremy Katz 2002-07-17 23:23:27 EDT
I'm not convinced that I really want to be bringing up network interfaces
unnecessarily.  With the current codebase, CD-ROM installs have all of the
networking modules available and so the module should definitely get loaded. 
Why not then just do an ifup eth0 in your %post?
Comment 2 Phil D'Amore 2002-07-18 08:52:03 EDT
I remember trying ifup eth0 and having it fail miserably.  I had resorted to
doing the following in the %post:

# Bring network interface up...
. /etc/sysconfig/network
. /etc/sysconfig/network-scripts/ifcfg-eth0
eval `/bin/ipcalc -b ${IPADDR} ${NETMASK}`
/sbin/ifconfig eth0 ${IPADDR} netmask ${NETMASK} broadcast ${BROADCAST}
/sbin/route add default gw ${GATEWAY}

Of course, this does not work if the interface is configured with DHCP.

Just to make sure, I will try it again and post the results.
Comment 3 Jeremy Katz 2003-01-03 02:20:23 EST
Any results of trying again?
Comment 4 Phil D'Amore 2003-01-03 10:25:36 EST
Sorry about taking so long.  Seems that this is at least working in 2.1AS, have
not yet tried in 8.0.  Originally, this was not working in 7.2, and this is what
I got on doing a ifup eth0:

Cannot open netlink socket: Address family not supported by protocol
modprobe: Can't open dependancies file /lib/modules/2.4.7-10BOOT/modules.dep (No
sufh file or directory)

Actually, I just tried 7.3 and it also works properly.  This is just a 7.2 issue.

At this point, I don't see much use in trying to fix this, so just go ahead and
resolve it however you want.
Comment 5 Jeremy Katz 2003-01-03 10:37:28 EST
Great, closing as current release

Note You need to log in before you can comment on or make changes to this bug.