Bug 68899 - GRUB used when LILO selected on text install
Summary: GRUB used when LILO selected on text install
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: limbo
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-07-15 20:09 UTC by Alan Olsen
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-19 03:18:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Olsen 2002-07-15 20:09:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020327

Description of problem:
If you use the text mode install, you are given the choice of using LILO instead
of GRUB. (My preference.) If you do this, it will still use GRUB as the boot
loader, but it will not boot because GRUB is not configured correctly. Stops
booting with a cryptic error message.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install using text mode
2. Select LILO as the boot loader.
3. Finish the install and watch the reboot fail.
	

Actual Results:  I get a weird GRUB error message on reboot. (Error 13 or
something similar.)

Expected Results:  It should have used LILO as the boot loader.

Additional info:

The graphical install does not give you a choice for using GRUB or LILO.  I
prefer LILO. It works. I am used to it. GRUB instalation and usage is very
non-intuative for me.  (I have been using Linux since the Yugdrasil beta.)

Comment 1 Jeremy Katz 2002-07-19 03:17:58 UTC
Fixed in CVS

Comment 2 Mike McLean 2002-07-31 20:27:26 UTC
Fix confirmed.
CLOSING->RAWHIDE


Note You need to log in before you can comment on or make changes to this bug.