Bug 68903 - initscripts (and other packages) should require redhat-release
initscripts (and other packages) should require redhat-release
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-15 16:31 EDT by Tarhon-Onu Victor
Modified: 2014-03-16 22:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-15 16:31:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tarhon-Onu Victor 2002-07-15 16:31:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020513
Netscape/7.0b1

Description of problem:
Initscripts (and maybe other packages) should require redhat-release because
they use it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -e redhat-release || rpm -e rawhide-release
2. init 6
3. Look at the screen while booting: "Welcome to: /etc/redhat-release: no such
file or directory" or something.



Actual Results:  I hit this minor bug while installing a redhat linux system rpm
by rpm (rpm -Uhv -r /mnt/mysystemtree) but it can be hit also by uninstalling
redhat-release or rawhide-release package which is not hard at all not being
required by no other package(s).

Additional info:

As long as initscripts (particulary rc.sysinit) will print an error if
/etc/redhat-release is not present then it should require redhat-release
(provided by redhat-release and rawhide-release packages).
This file is required by many other scripts from various packages to establish
the distribution name or/and other thinkgs.
Comment 1 Bill Nottingham 2002-08-13 21:56:29 EDT
Will be fixed in 6.89-1.

Note You need to log in before you can comment on or make changes to this bug.