Bug 68912 - 2.4.18-5 NVidia driver module won't install
Summary: 2.4.18-5 NVidia driver module won't install
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
low
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-15 21:52 UTC by Frazer Williams
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-16 02:56:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frazer Williams 2002-07-15 21:52:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
Using up2date I updated from 2.4.18-4 to 2.4.18-5.  The system rebooted
under the new kernel fine, but barfed on trying to start X windows.  My
video card is NVidia GeForce2 MXR.  Further investigation showed the NVidia
driver was not in the modules/2.4.8-5 directory.  I copied the driver from the
2.4.18-4 directory and attempted an insmod on it.  The insmod failed because of
several unresolved dependencies.

The computer is new and 2.4.18-4 was installed on it by Dell.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot the 2.4.18-5 kernel
2. Login and try to start X or try to insmod the NVdriver module
3. 
	

Actual Results:  X refused to start and I couldn't insmod NVdriver because of
unresolved dependencies.

Expected Results:  Either X should have started, or at least I should have been
able to insmod NVdriver

Additional info:

Comment 1 Frazer Williams 2002-07-15 23:40:22 UTC
After looking at the Loadable Kernel MOdule HOWTO, and the outputs of
the insmod NVdriver errors and cat /proc/ksyms under the 2.4.28-5 kernel, I
think the problem is related to symbol versioning.  For example, insmod
reports

   /lib/modules/2.4.18-5/kernel/drivers/video/NVdriver: unresolved symbol
     pci_read_config_word_R46710516

whereas I find the following symbol in /proc/ksyms

   c01ab960 pci_read_config_word_R4433deb0

Under 2.4.18-4, the symbol the driver wants is available in /proc/ksyms.


Comment 2 Clark Tompsett 2002-07-16 02:56:36 UTC
You need to recompile the Nvidia driver against the 2.4.18-5 source code.  I
have to do a make mrproper, make oldconfig, make dep then go to the directory
with the Nvidia source and rebuild the driver.  I do this with the 2.4.18-5
kernel booted.

Comment 3 Arjan van de Ven 2002-07-16 06:44:17 UTC
Yes you need to compile kernel modules against the kernel you want to load them in.
You don't need a make mrproper or anything; just the kernel-source installed
should work. 

However nvidia driver is not supported, closing as NOTABUG


Note You need to log in before you can comment on or make changes to this bug.