Bug 689182 - Missing dependencies in emacs RPM
Summary: Missing dependencies in emacs RPM
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 688554
TreeView+ depends on / blocked
 
Reported: 2011-03-20 05:23 UTC by Mattias Ellert
Modified: 2011-04-06 07:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-22 07:12:49 UTC


Attachments (Terms of Use)

Description Mattias Ellert 2011-03-20 05:23:54 UTC
Description of problem:
The emacs RPM in missing all library dependencies.

Version-Release number of selected component (if applicable):
emacs-1:23.3-3.fc16

How reproducible:
Always

Steps to Reproduce:
1. Install emace
2. Try to start it
3. It fails to start due to missing libraries:

emacs: error while loading shared libraries: libgif.so.4: cannot open shared object file: No such file or directory

The emacs package in fc15 and earlier have the correct dependencies. Compare the list of Requires for:

https://koji.fedoraproject.org/koji/rpminfo?rpmID=2325614 (fc15) and
https://koji.fedoraproject.org/koji/rpminfo?rpmID=2457908 (fc16/rawhide)

Actual results:
Broken installation with missing dependencies

Expected results:
Working installation with all dependencies installed

Additional info:
For a local installation you would normally have most of the libraries installed anyway, but for a package build in koji where you are doing an *.el → *.elc compilation the correct dependencies in the RPM is crucial in order not to cause FTBFS errors. For this reason I have marked the bug as urgent.

Comment 1 Karel Klíč 2011-03-21 18:50:11 UTC
I tried to rebuild both the newest emacs and also older F-15 emacs in Rawhide, and both are missing dependencies.

Emacs from Fedora 15 built on Rawhide:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2929507

Looks like an rpm issue more than a packaging error in emacs.
Changing component to rpm for further investigation.

Comment 2 Panu Matilainen 2011-03-22 06:17:21 UTC
I see...

[pmatilai@localhost ~]$ file /usr/bin/emacs-23.2
/usr/bin/emacs-23.2: sticky ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.18, stripped

The file classification rules in rpm >= 4.9.0 are stricter than before and rpm doesn't expect the "sticky" word in there (I had no idea libmagic would ever output such a thing, sticky executables aren't that common...) Anyway, will fix shortly.

Comment 3 Panu Matilainen 2011-03-22 07:12:49 UTC
Fixed in rpm-4.9.0-4 in rawhide and f15 update in progress.

Comment 4 Fedora Update System 2011-03-22 07:35:44 UTC
rpm-4.9.0-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rpm-4.9.0-4.fc15

Comment 5 Fedora Update System 2011-04-06 07:04:19 UTC
rpm-4.9.0-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rpm-4.9.0-5.fc15


Note You need to log in before you can comment on or make changes to this bug.