Bug 68921 - Need UI for package group screen to display/warn about dependencies better
Need UI for package group screen to display/warn about dependencies better
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-07-15 20:20 EDT by Need Real Name
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-17 10:49:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-15 20:20:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
Deselected emacs and postgresql during package selection but they were still 
installed onto the system.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Deselect emacs and postgres from packages.
2.They still were installed.
3.
	

Additional info:
Comment 1 Jeremy Katz 2002-07-17 23:37:36 EDT
Where did you deselect them?  Were they needed as dependencies of anything else
you installed?  Which postgresql packages were installed?
Comment 2 Need Real Name 2002-07-18 14:14:21 EDT
I deselected them during the install process where select which groups of
packages you would like to install.  I'm almost positive they were not
dependencies for anything else, but I will have to verify that and get back with
you.
Comment 3 Need Real Name 2002-07-22 08:41:08 EDT
Ok, I did a reinstall of Limbo and here is what I have discovered.  In anaconda
where you select the checkboxes as to which packages you would like installed I
unchecked emacs and SQL Database.  So then I went into the individual package
selection option.  Sure, enough emacs and postgresql were still selected even
though I did not select them.  So I left that as is.  Then after clicking next
it told me a dependency of package psgml was emacs.  So I'm guessing that's what
happened the first time I installed it.  So everything may acutally be ok there.
 The only thing I was uncertain about is why emacs was still selected in the
individual package selection even though I didn't select it.  Unless a
dependency check was done prior to this.  

As for postgres it was still installled even though I didn't select it.  The
packages that were installed were postgresql and postgresql-libs.
Comment 4 Jeremy Katz 2002-07-22 12:40:08 EDT
We've changed the way emacs is handled now to try to clear up that bit of
confusion.  postgresql you only got the libs for, so you must have installed
something which required them.  If you try to remove the package, it will tell
you what the dependencies are.
Comment 5 Need Real Name 2002-07-24 14:08:31 EDT
Ok, I did an rpm -e on postgresql-libs and the dependencies are mod_auth_pgsql,
postgresql, and php-pgsql.  So it looks like the dependeny issue may have been
the case I just assumed it was ask you as anaconda usually does if you would
like to install packages to satisfy dependencies or not for packages you have
not explicitly selected.
Comment 6 Michael Fulbright 2002-07-24 14:52:30 EDT
I want to add some code to tell you when you are unselecting things that you
can't unselect a particular package because (list of other packages) depends on
it.  At least it won't be a surprise.
Comment 7 Need Real Name 2002-07-24 15:26:45 EDT
That would be excellent!  Let me know if you need anything further of me.

Note You need to log in before you can comment on or make changes to this bug.