Bug 68931 - [RFE] lvm 1.0.5
[RFE] lvm 1.0.5
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-15 23:08 EDT by James Manning
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-10 07:59:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Manning 2002-07-15 23:08:18 EDT
Changelog for 1.0.4 to 1.0.5

Driver
------
o Fixed pvmove lock bug in lvm_do_le_remap
o use blk_ioctl() of blkpg.c in lvm_blk_ioctl in order to support BLKBSZSET
  and other general ioctls
o Fixed OBO error on vg array access


Tools
-----

o vgscan
  - Workaround for minor metadata corruption bug in 1.1rc,
    for those downgrading.
o vgcfgbackup
  - running vgcfgbackup with no VGs is not an error
Comment 1 Trond Eivind Glomsrxd 2002-07-16 11:40:46 EDT
The userspace components are not upgraded because they need to stay in sync with
the kernel part.
Comment 2 Arjan van de Ven 2002-07-16 11:44:14 EDT
we ship a rather modified lvm because the original one eats data alive ;(
but that means we need modified tools too.
Comment 3 James Manning 2002-07-16 11:52:34 EDT
is this in ref to ext3's alleged misbehavior?

https://lists.sistina.com/pipermail/linux-lvm/2002-July/011799.html

yeah, the thread's talking about LVM2, of course, just curious
Comment 4 James Manning 2002-07-16 11:58:21 EDT
oh, and it's prob. worth checking the whole thread, of course, since Jens and
Andrew got to chatting as well

https://lists.sistina.com/pipermail/linux-lvm/2002-July/thread.html#11799
Comment 5 Stephen Tweedie 2002-07-23 15:08:44 EDT
No, the LVM2/ext3 collision is over who owns the b_private field.  Current LVM2
sources include a collision-avoidance for that, and once things are integrated
in 2.5 there will be no problem since ext3 and LVM2 will be using separate data
structures there (buffer_head versus bio structs.)

The "eats data alive" bug in LVM is due to pvmove being a complex operation done
partly in user-space (so it is deadlock-prone) and with incorrect locking and
cache management (so it can corrupt data).  We fixed that in our release and
sent the patch upstream, but it is not merged in Sistina's LVM yet.

I'll look into the 1.0.5 changes to see if there are bug-fixes we should merge
into our packages.
Comment 6 Stephen Tweedie 2004-09-10 07:59:54 EDT
LVM is deprecated; we are using the upstream dm packages in current
Fedora kernels.

Note You need to log in before you can comment on or make changes to this bug.