Bug 689314 - [abrt] gkrellm-2.3.4-3.fc14: gkrellm_exit: Process /usr/bin/gkrellm was killed by signal 6 (SIGABRT)
[abrt] gkrellm-2.3.4-3.fc14: gkrellm_exit: Process /usr/bin/gkrellm was kille...
Status: CLOSED DUPLICATE of bug 678896
Product: Fedora
Classification: Fedora
Component: atk (Show other bugs)
14
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
abrt_hash:35871db1f3a8ae72bf0e7859363...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-20 23:38 EDT by Dale Snell
Modified: 2012-03-21 12:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 12:14:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (14.83 KB, text/plain)
2011-03-20 23:38 EDT, Dale Snell
no flags Details

  None (edit)
Description Dale Snell 2011-03-20 23:38:21 EDT
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 15185 bytes
cmdline: /usr/bin/gkrellm --sm-client-id 10eb7c9f563ef55a51127112828413014700000017700036
component: gkrellm
Attached file: coredump, 13742080 bytes
crash_function: gkrellm_exit
executable: /usr/bin/gkrellm
kernel: 2.6.35.11-83.fc14.x86_64
package: gkrellm-2.3.4-3.fc14
rating: 4
reason: Process /usr/bin/gkrellm was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1300635940
uid: 500

comment
-----
I was looking at a YouTube video in Firefox, and abrt popped up with a crash alert.  I have no idea what, if any, relationship there would be between them.   GKrellM appeared to keep running smoothly -- there was no interruption in any of the graphs.  Other than that, I don't know what to say.  I don't know what caused the crash, and I have no idea how to re-create it.  There was a previous crash this month, but abrt didn't report it.  

When the crash occurred, there was a popup notification that the core file was too big.  I hope it wasn't; I recently added about five gigabytes to /var, and set the coresize to unlimited.  (This is the second time abrt has told me this; it may be an error on abrt's part.)

Anyway, if you need me to run any tests, let me know, I'd be happy to help.

How to reproduce
-----
1.  foo
2.
3.
Comment 1 Dale Snell 2011-03-20 23:38:23 EDT
Created attachment 486539 [details]
File: backtrace
Comment 2 Hans de Goede 2011-03-21 04:58:40 EDT
The backtrace points to a failure in atk-spi when it tries to clean up some things on exit from a registered exit handler, changing component.

Dale, looking at the backtrace it suggests this crash happened while you exited from gkrellm, did you quit gkrellm?
Comment 3 Dale Snell 2011-03-21 19:39:47 EDT
(In reply to comment #2)
> The backtrace points to a failure in atk-spi when it tries to clean up some
> things on exit from a registered exit handler, changing component.

Would that be related to bug 657967?  That one seems responsible for quite a number of seemingly-random failures.

> Dale, looking at the backtrace it suggests this crash happened while you exited
> from gkrellm, did you quit gkrellm?

No, I hadn't.  It's by far my favorite tool for displaying system status.  I have it set to start when I log in, and it stays running until I log out.  To tell the truth, GKrellM did not seem to have died at all, since the graphs were uninterrupted.

BTW, you may be interested in bug 689314.  It's the same sort of thing (at least from my point of view).  This bug may be a duplicate of that one, I don't know.  I'm afraid I'd forgotten about it when I submitted this bug report.
Comment 4 Hans de Goede 2011-03-22 04:00:00 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > The backtrace points to a failure in atk-spi when it tries to clean up some
> > things on exit from a registered exit handler, changing component.
> 
> Would that be related to bug 657967?  That one seems responsible for quite a
> number of seemingly-random failures.
> 

At a first glance that one seems unrelated.

> > Dale, looking at the backtrace it suggests this crash happened while you exited
> > from gkrellm, did you quit gkrellm?
> 
> No, I hadn't.  It's by far my favorite tool for displaying system status.  I
> have it set to start when I log in, and it stays running until I log out.  To
> tell the truth, GKrellM did not seem to have died at all, since the graphs were
> uninterrupted.
> 

Weird, this makes me wonder if the backtrace is correct at all. Maybe abrt detected some older core file of a previous crash and used that ??

> BTW, you may be interested in bug 689314.  It's the same sort of thing (at
> least from my point of view).  This bug may be a duplicate of that one, I don't
> know.  I'm afraid I'd forgotten about it when I submitted this bug report.

Erm, this is bug 689314, so you probably meant another bug ?
Comment 5 Dale Snell 2011-03-23 13:20:53 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > 
> > BTW, you may be interested in bug 689314.  It's the same sort of thing (at
> > least from my point of view).  This bug may be a duplicate of that one, I don't
> > know.  I'm afraid I'd forgotten about it when I submitted this bug report.
> 
> Erm, this is bug 689314, so you probably meant another bug ?

Ack!  That's... interesting.  I seem to have encountered a bug in Bugzilla.  On my "My Bugs" page, _this_ bug is listed as being assigned to mclasen@redhat.com, while the older bug report -- bug 678896, which is the one I'd meant to reference in my previous comment -- is shown assigned to you.  And since I'd gone by the assignee field when doing my cut-and-paste, I got the wrong number.

As for abrt getting confused and using an old backtrace, I suppose it's possible.  /var/spool/abrt does contain several old reports, including the older gkrellm report.  However, I looked at the backtraces and they aren't the same.  The one referenced in this bug report is the one from the most recent gkrellm crash.  So I don't think abrt is getting confused.
Comment 6 abrt-bot 2012-03-21 12:14:21 EDT
Backtrace analysis found this bug to be similar to bug #678896, closing as duplicate.

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 678896 ***

Note You need to log in before you can comment on or make changes to this bug.