Bug 689381 - tcsh obeys printexitvalue for back-ticks
tcsh obeys printexitvalue for back-ticks
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tcsh617 (Show other bugs)
5.4
All Linux
urgent Severity medium
: rc
: ---
Assigned To: Vojtech Vitek
: Patch, Reopened
Depends On: 531353
Blocks: 502912 590060 579251 640252
  Show dependency treegraph
 
Reported: 2011-03-21 05:46 EDT by Ondrej Vasik
Modified: 2015-03-04 18:57 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, if the "printexitvalue" variable was set, tcsh returned the exit code number as a part of the command output, rendering the output unusable. This has happened due to a missing job status flag. The proper flag has been set and the command output is now correct.
Story Points: ---
Clone Of: 531353
Environment:
Last Closed: 2011-07-21 04:47:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 5 Miroslav Svoboda 2011-07-01 18:04:56 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, if the "printexitvalue" variable was set, tcsh returned the exit code number as a part of the command output, rendering the output unusable. This has happened due to a missing job status flag. The proper flag has been set and the command output is now correct.
Comment 6 errata-xmlrpc 2011-07-21 04:47:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1072.html
Comment 7 errata-xmlrpc 2011-07-21 08:10:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1072.html

Note You need to log in before you can comment on or make changes to this bug.