Bug 68943 - screws X11 mouse
Summary: screws X11 mouse
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-mouse   
(Show other bugs)
Version: limbo
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-07-16 12:38 UTC by Harald Hoyer
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-09 03:17:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config generated by redhat-config-mouse on configuring USB mouse (3.00 KB, text/plain)
2002-08-03 20:47 UTC, Jack Neely
no flags Details

Description Harald Hoyer 2002-07-16 12:38:34 UTC
upon startup, redhat-config-mouse make my mouse misbehaving

Comment 1 Bill Nottingham 2002-07-17 02:42:01 UTC
What sort of mouse do you have?

Comment 2 Harald Hoyer 2002-07-17 10:05:26 UTC
M$ Wheel Mouse (IMPS/2)

Comment 3 Matt Harvey 2002-07-20 09:37:28 UTC
Same here. MS Intellimouse PS/2 wheel. Running redhat-config-mouse in X causes
the mouse to act weird and then the program dies and it goes back to normal.
Running mouseconfig from the console modified my XF86Config in such a way that X
would not start. I had to add CorePointer and CoreKeyboard directives into the
ServerLayout section to get it working again.

The reason I was running the mouse tool in the first place is that the
wheel/third button did not work after standard install. In hidsight, it looks
like the way to fix this was to change the mouse device from /dev/input/mice to
/dev/psaux, in my particular case of Intellimouse PS/2 Wheel.

Comment 4 Jack Neely 2002-08-03 20:42:08 UTC
Seem on my Dell I4000 laptop too.  I have a USB mouse that redhat-config-mouse
doesn't work for...it just borks my XF86Config as described above.  The PS/2
touchpad and trackpoint work though...I believe that was configured by anaconda.
 I'll attach the config file the redhat-config-mouse generates.

Comment 5 Jack Neely 2002-08-03 20:47:31 UTC
Created attachment 68764 [details]
XF86Config generated by redhat-config-mouse on configuring USB mouse

Comment 6 Brent Fox 2002-08-09 03:17:37 UTC
This should be fixed in 0.9.9-2.  


QA, please verify.  I think we have some IntelliMouse PS/2 mice to test with.

Comment 7 Jay Turner 2002-08-13 18:58:07 UTC
Appears to be working lots better with redhat-config-mouse-0.9.9-3.


Note You need to log in before you can comment on or make changes to this bug.