Bug 68961 - kernel fails an assertion
kernel fails an assertion
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-16 11:32 EDT by Mike Palczewski
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-16 11:36:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Palczewski 2002-07-16 11:32:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/0

Description of problem:
Using kernel-smp-2.4.18-3 on a four way 500Mhz Xeon machine with ext3
filesystems I got this very worysome kernel message.   It looked like it wanted
to be reported.  Since this is a redhat kernel I will first post this bug here
before posting to the linux-kernel list.

(scsi0:A:0:0): Locking max tag count at 64
Assertion failure in journal_commit_transaction() at commit.c:535:
"buffer_jdirty(bh)"
------------[ cut here ]------------
kernel BUG at commit.c:535!
invalid operand: 0000
autofs eepro100 ipchains ext3 jbd aic7xxx sd_mod scsi_mod  
CPU:    1
EIP:    0010:[<f88580e4>]    Not tainted
EFLAGS: 00010286

EIP is at journal_commit_transaction [jbd] 0xb04 (2.4.18-3smp)
eax: 0000001c   ebx: 0000000a   ecx: c02eee60   edx: 000036f1
esi: ea54f730   edi: d98b5ae0   ebp: f6b88000   esp: f6b89e78
ds: 0018   es: 0018   ss: 0018
Process kjournald (pid: 147, stackpage=f6b89000)
Stack: f885eeee 00000217 f6b4e000 00000000 00000fb4 eb6ac04c 00000000 f68dbcc0 
       f5e31c70 0000047c 00000286 00000286 00000001 c1e1dde0 d1815960 d1815840 
       e7137260 f2b184e0 f2b18c60 f2b18ea0 f2b185a0 ec7ba3c0 ec7ba0c0 ec7bad20 
Call Trace: [<f885eeee>] .rodata.str1.1 [jbd] 0x26e 
[<c010758d>] __switch_to [kernel] 0x3d 
[<c0119048>] schedule [kernel] 0x348 
[<f885a7d6>] kjournald [jbd] 0x136 
[<f885a680>] commit_timeout [jbd] 0x0 
[<c0107286>] kernel_thread [kernel] 0x26 
[<f885a6a0>] kjournald [jbd] 0x0 


Code: 0f 0b 5a 59 6a 04 8b 44 24 18 50 56 e8 4b f1 ff ff 8d 47 48 


Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce


Additional info:
Comment 1 Arjan van de Ven 2002-07-16 11:36:07 EDT
Have you read
http://rhn.redhat.com/errata/RHBA-2002-085.html
?
Comment 2 Mike Palczewski 2002-07-16 11:41:47 EDT
sorry to waste your time.  I should have checked for updates first.

Note You need to log in before you can comment on or make changes to this bug.