Bug 68971 - VNCOPTIONS to vncserver init script
Summary: VNCOPTIONS to vncserver init script
Status: CLOSED DUPLICATE of bug 60176
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: vnc   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-16 16:46 UTC by Rex Dieter
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-16 16:48:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to vncservers.init to implement use of VNCOPTIONS (697 bytes, patch)
2002-07-16 16:48 UTC, Rex Dieter
no flags Details | Diff

Description Rex Dieter 2002-07-16 16:46:21 UTC
I found the need/desire to use Xvnc options differing from the default for 
some vnc sessions I wanted to setup on some machines of mine.  I found it 
pretty easy to implement. 
 
I added a line to /etc/sysconfig/vncservers, using some sample options (for 
illustration): 
VNCOPTIONS="-depth 16 -geometry 800x600 -alwaysshared" 
 
and then modified the vncserver.init script, in particular, the line launching 
the vncserver process from: 
...] && vncserver :${display%%:*}\"" 
to 
...] && vncserver :${display%%:*} $VNCOPTIONS \"" 
 
I suppose this idea could also be extended to include display-specific 
options, say, I want -depth 16 to apply only to to the vnc server on display 
:1.  
 
I'll include a patch detailing the modifications to the init script.

Comment 1 Rex Dieter 2002-07-16 16:48:30 UTC
Created attachment 65547 [details]
patch to vncservers.init to implement use of VNCOPTIONS

Comment 2 Tim Waugh 2002-07-17 09:35:31 UTC
Thanks.  I'm marking this as a duplicate of a previous request for the same thing.

*** This bug has been marked as a duplicate of 60176 ***


Note You need to log in before you can comment on or make changes to this bug.