Bug 689774 - rawhide: changes in GTK force anaconda to be more strict about the TreeModel types.
Summary: rawhide: changes in GTK force anaconda to be more strict about the TreeModel ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:b9fbe5becddf68be1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-22 12:32 UTC by James Laska
Modified: 2014-09-30 23:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-25 06:57:23 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (385.83 KB, text/plain)
2011-03-22 12:32 UTC, James Laska
no flags Details

Description James Laska 2011-03-22 12:32:41 UTC
The following was filed automatically by anaconda:
anaconda 15.24 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/datacombo.py", line 43, in append
    self.store[iter] = (text, data)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/lvm_dialog_gui.py", line 269, in createPEOptionMenu
    peCombo.append(val, curpe)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/lvm_dialog_gui.py", line 1345, in __init__
    self.peCombo = self.createPEOptionMenu(self.vg.peSize * 1024)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1713, in editLVMVolumeGroup
    device, isNew)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1638, in editCB
    self.editLVMVolumeGroup(device)
TypeError: value is of wrong type for this column

Comment 1 James Laska 2011-03-22 12:32:45 UTC
Created attachment 486780 [details]
Attached traceback automatically from anaconda.

Comment 2 James Laska 2011-03-22 12:33:55 UTC
= Steps to reproduce =

1) Do an autopart install
2) Start another install, but use 'custom' partitioning
3) Attempt to edit the LVM volume group created in step#1

Comment 3 Martin Gracik 2011-03-22 12:42:37 UTC

*** This bug has been marked as a duplicate of bug 682543 ***

Comment 4 Ales Kozumplik 2011-03-25 06:57:23 UTC
This is fixed on the master branch by 7673b209201444d7ea3f293120a904f3e7370e03.


Note You need to log in before you can comment on or make changes to this bug.