Bug 68979 - Infinite loop in analyze_tree() in glibc on Limbo
Infinite loop in analyze_tree() in glibc on Limbo
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.3
athlon Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-16 14:29 EDT by Volodymyr M. Lisivka
Modified: 2016-11-24 10:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 16:55:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Volodymyr M. Lisivka 2002-07-16 14:29:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020611

Description of problem:
When mc try to compile regular expressions it crased in function regcomp().
Backtrace shows few thousands calls to function analyze_tree() from
/lib/i686/libc.6.so.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run mc
2. Press F4
3. or Press F5 and Ok.


Actual Results:  mc crased


Additional info:
Comment 1 Jakub Jelinek 2002-07-18 04:41:02 EDT
Please try glibc-2.2.90-15 and mc-4.5.55-9 from rawhide. There were bugs
on both sides (glibc and mc) wrt. regex handling.
Comment 2 Alan Cox 2002-12-15 16:55:19 EST
Works for me in 8.0

Note You need to log in before you can comment on or make changes to this bug.