Bug 689829 - ELFOSABI_LINUX is incorrectly set in a dynamic ifunc-using executable
Summary: ELFOSABI_LINUX is incorrectly set in a dynamic ifunc-using executable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: binutils
Version: 6.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Andreas Schwab
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-22 14:58 UTC by Siddhesh Poyarekar
Modified: 2018-11-26 18:57 UTC (History)
5 users (show)

Fixed In Version: binutils-2.20.51.0.2-5.21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:00:04 UTC
Target Upstream Version:


Attachments (Terms of Use)
Backported patch, tweaked to apply to RHEL-6 (3.83 KB, text/plain)
2011-03-22 14:58 UTC, Siddhesh Poyarekar
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1523 normal SHIPPED_LIVE binutils bug fix and enhancement update 2011-12-06 00:50:07 UTC

Description Siddhesh Poyarekar 2011-03-22 14:58:09 UTC
Created attachment 486814 [details]
Backported patch, tweaked to apply to RHEL-6

Description of problem:
ELFOSABI_LINUX is incorrectly set in a dynamic ifunc-using executable.

Version-Release number of selected component (if applicable):
binutils-2.20.51.0.2-5.11.el6

How reproducible:
Always

Steps to Reproduce:
$ cat > bar.c <<EOF
int main () { return 42; }
EOF
$ gcc foo.c
$ readelf a.out | grep OS
  
Actual results:
  OS/ABI:                            UNIX - Linux

Expected results:
  OS/ABI:                            UNIX - System V

Additional info:

This has been fixed upstream:

http://sourceware.org/cgi-bin/cvsweb.cgi/src/bfd/elf32-i386.c.diff?r1=1.229&r2=1.230&cvsroot=src
http://sourceware.org/cgi-bin/cvsweb.cgi/src/bfd/elf32-ppc.c.diff?r1=1.278&r2=1.279&cvsroot=src
http://sourceware.org/cgi-bin/cvsweb.cgi/src/bfd/elf32-sparc.c.diff?r1=1.91&r2=1.92&cvsroot=src
http://sourceware.org/cgi-bin/cvsweb.cgi/src/bfd/elf64-ppc.c.diff?r1=1.318&r2=1.319&cvsroot=src
http://sourceware.org/cgi-bin/cvsweb.cgi/src/bfd/elf64-sparc.c.diff?r1=1.120&r2=1.121&cvsroot=src
http://sourceware.org/cgi-bin/cvsweb.cgi/src/bfd/elf64-x86-64.c.diff?r1=1.190&r2=1.191&cvsroot=src
http://sourceware.org/cgi-bin/cvsweb.cgi/src/ld/testsuite/ld-ifunc/ifunc.exp.diff?r1=1.8&r2=1.9&cvsroot=src

Comment 6 errata-xmlrpc 2011-12-06 17:00:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1523.html


Note You need to log in before you can comment on or make changes to this bug.