Bug 689853 - Providing native systemd file for upcoming F15 Feature Systemd
Providing native systemd file for upcoming F15 Feature Systemd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Hrozek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-22 12:17 EDT by Jóhann B. Guðmundsson
Modified: 2011-04-26 13:35 EDT (History)
5 users (show)

See Also:
Fixed In Version: sssd-1.5.6-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-21 22:19:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Native systemd service file (210 bytes, text/plain)
2011-03-22 12:17 EDT, Jóhann B. Guðmundsson
no flags Details
With After=syslog.target network.target (239 bytes, text/plain)
2011-03-22 12:34 EDT, Jóhann B. Guðmundsson
no flags Details
resubmitted without network.target local-fs.target remote-fs.target in After (190 bytes, text/plain)
2011-03-31 08:10 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-03-22 12:17:58 EDT
Created attachment 486834 [details]
Native systemd service file

Description of problem:

The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to packaging and installing systemd Service files.

To learn more about Systemd daemon see [3].

To view old SysV with the new Systemd site by site see for your component see [4]

If you have any question dont hesitate to ask them on this bug report.

1.http://fedoraproject.org/wiki/Features/systemd

2.https://fedoraproject.org/wiki/Systemd_Packaging_Draft

3.http://0pointer.de/public/systemd-man/daemon.html

4.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/compatability 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-03-22 12:34:09 EDT
Created attachment 486842 [details]
With After=syslog.target network.target

Just noticed that I forgot to add after systlog.target and network target thus resubmitting..
Comment 2 Simo Sorce 2011-03-22 12:40:39 EDT
why the network target ?
Does it mean sssd startup will be delayed until the network is up ?
Although sssd uses network resources it can handle a local db and it does handle offline operations by default including sensing on its own when the network is up in order to go online.

So I am not sure it really needs to be configured to wwait for the network to be up.

Also I se you have as After remote-fs.target too, why is that ?
Comment 3 Jóhann B. Guðmundsson 2011-03-22 13:21:27 EDT
I only added the remote.fs,target network.target ( and the local-fs,target ) because I thought there was a dependency issue due to this comment in the SysV init file 

### BEGIN INIT INFO
# Provides: sssd
# Required-Start: $remote_fs <---???

Feel free to remove both network.target local-fs.target remote-fs.target if not needed. ( so the line should just be After=syslog.target )

You also might want to add Conflicts=nscd.service if necessary in the [Unit] section of the service file.
Comment 4 Lennart Poettering 2011-03-31 07:44:43 EDT
local-fs.target is never needed in systemd, since that is implied for normal services.
Comment 5 Jóhann B. Guðmundsson 2011-03-31 08:10:04 EDT
Created attachment 489051 [details]
resubmitted without network.target local-fs.target remote-fs.target in After
Comment 6 Stephen Gallagher 2011-04-04 08:58:24 EDT
Jakub, please take a look at this and if it's acceptable, please add this to source control and add a new configure flag to install this config file instead of the Sys V init script.
Comment 7 Jakub Hrozek 2011-04-05 11:32:35 EDT
(In reply to comment #6)
> Jakub, please take a look at this and if it's acceptable, please add this to
> source control and add a new configure flag to install this config file instead
> of the Sys V init script.

Sure, the upstream ticket is https://fedorahosted.org/sssd/ticket/837
Comment 8 Fedora Update System 2011-04-13 10:25:54 EDT
sssd-1.5.5-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/sssd-1.5.5-2.fc15
Comment 9 Fedora Update System 2011-04-13 20:33:44 EDT
Package sssd-1.5.5-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sssd-1.5.5-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/sssd-1.5.5-2.fc15
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-04-15 00:31:17 EDT
Package sssd-1.5.5-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sssd-1.5.5-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/sssd-1.5.5-3.fc15
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2011-04-20 23:00:48 EDT
Package sssd-1.5.6-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sssd-1.5.6-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/sssd-1.5.6-1.fc15
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2011-04-21 22:19:39 EDT
sssd-1.5.6-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Bill Nottingham 2011-04-26 13:35:24 EDT
Moving systemd service RFEs to rawhide.

At this point, it is not appropriate in the Fedora 15 cycle to add these. Furthermore, at this point, we are still finalizing the packaging guidelines to handle SysV -> systemd upgrades.

We therefore request:
- wait until there are packaging guidelines (this will be announced on the devel list). This ensures that upgrades will work smoothly and we/you won't have to do multiple sets of changes.
- work on these sorts of changes for Fedora 16 where necessary, not Fedora 15, as we're trying to fix things for release.
- do *not* change a service from SysV to systemd in an existing release (such as Fedora 15), as this is the sort of behavior change that goes against our update policy, documented as https://fedoraproject.org/wiki/Updates_Policy

Note You need to log in before you can comment on or make changes to this bug.