Bug 68993 - evolution-addressbook crashes
evolution-addressbook crashes
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-07-16 15:35 EDT by Joachim Kunze
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-29 16:37:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Typescript of a gdb session (11.54 KB, application/octet-stream)
2003-02-14 15:48 EST, Miloslav Trmac
no flags Details
Backtrace (4.45 KB, text/plain)
2003-04-07 07:26 EDT, Joachim Kunze
no flags Details

  None (edit)
Description Joachim Kunze 2002-07-16 15:35:48 EDT
Description of Problem:
The evolution-addressbook crashes very often if I generate a lot of new contacts
and open already existing contacts

Version-Release number of selected component (if applicable):
1.0.3, 1.0.7, 1.0.8-3 (it doesn't depend on the version)

How Reproducible:
unfortunately the error occurs 'undeterministic'
just type in new contacts and open existing contacts 
after a few 'cycles' the evolution-addressbook will crash
Comment 1 Jeremy Katz 2002-07-29 00:08:49 EDT
I can't seem to reproduce this -- when it crashes, does bug buddy pop up and
allow you to get a stack trace?
Comment 2 Joachim Kunze 2002-07-29 21:20:46 EDT
No,I only receive the message, that the component evolution-adressbook has
crashed and that it has to be restarted...

In the current version of the beta I use (re0728) with evolution-1.0.8-4 the
error can't be reproduced any more - how do we proceed? Shall we close the bug
then - or shall I still 'have an eye' on the application due to the
undeterministic behaviour?
Comment 3 Miloslav Trmac 2002-07-30 13:43:32 EDT
Hello,
this may or may not be the same bug, but I am able to reproduce it 100%, so you
might be interested (although it applies to RH 7.3 - evolution 1.0.3-6).
(Sorry, I'm typing it from memory, so some of the texts may be a bit different.)
* create a new account (or otherwise "clean state"), with locale cs_CZ (maybe
isn't relevant)
* Start Evolution (In the wizard I have used "none" incoming mail server,
sendmail as outgoing mail, but this is probably not relevant)
* File/Import, Single file, std.vcf (from KMail, I'll send it by mail), type
VCard (BTW, why doesn't autodetection work?), import to Contacts
* Wonder why it bothers you with "importer not ready, waiting 5 seconds"
* Open Contacts. You'll see strange characters there (the std.vcf file is in
UTF-8, I don't know what Evolution expects). The very first address book entry
is labeled "AdAimek, Filip" (3rd and 4th characters are a bit different)
* Double-click on it, click on Full name
* Instead of "AdAImek", you'll see "Ad__mek" (don't forget to wonder again);
delete the underscores to have "Admek", click OK
* in the "File As", select "Admek, Filip"
* click "Save and continue" in the toolbar
* double-click on the next address book entry (the one below the "Admek, Filip" one)
* See the dialog that evolution-addressbook crashed, and wonder where the core
file has disappeared, even with ulimit -c unlimited
Comment 4 Richard Hult 2002-08-19 17:32:24 EDT
Confirmed crash on null, evolution-addressbook crashed for me. No stack trace
unfortunately.
Comment 5 Jeremy Katz 2003-02-11 00:43:41 EST
Have you tried this with evolution 1.2.x in rawhide/phoebe?
Comment 6 Miloslav Trmac 2003-02-14 15:46:30 EST
OK, here is a stack trace.
Clean install of Phoebe 8.0.93, cs_CZ.UTF-8, gtkhtml-1.1.8-3, evolution-1.2.2-1
Occured when clicking on the down arrow of the date widget for "birthday"
when adding a new contact.

I've experienced a crash in other place, but was not able to reproduce it
and get the backtrace.

Comment 7 Miloslav Trmac 2003-02-14 15:48:37 EST
Created attachment 90097 [details]
Typescript of a gdb session
Comment 8 Joachim Kunze 2003-04-07 07:26:46 EDT
Created attachment 90946 [details]
Backtrace
Comment 9 Joachim Kunze 2003-04-07 07:29:42 EDT
All,

in my last comment you've found a backtrace of the last crash of evo. I'm using
now version 1.2.2-5 with RHL 9 and I'm still experiencing the same problem
Comment 10 Jeremy Katz 2003-06-29 16:37:48 EDT
I've yet to reproduce this and can't reproduce on trying with 1.4.x.  Assuming
its fixed there, reopen if not.

Note You need to log in before you can comment on or make changes to this bug.