Bug 69001 - 'Skip Registration' no longer works
Summary: 'Skip Registration' no longer works
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server   
(Show other bugs)
Version: unspecified
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-16 21:31 UTC by Matt Jamison
Modified: 2007-07-31 19:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-17 20:26:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Josef Komenda 2002-07-16 21:31:53 UTC
Description of Problem: After running the satellite installer, re-running it
with 'Skip Registration' checked jumps to the satellite Satellite cert screen,
and you cannot enter the previous cert, nor can you leave it blank. To proceed,
you must delete the currently registered system, and re-register.


Version-Release number of selected component (if applicable): see 63780


How Reproducible: run sat installer 2x with 'Skip Registration' checked the
second time.

Comment 1 Adrian Likins 2002-07-16 21:56:13 UTC
Hmm, not sure I understand. Does something throw an error message?

The installer isnt really designed to be ran more than once.

Comment 2 Josef Komenda 2002-07-17 15:27:15 UTC
Ok, I performed a kickstart to sat-inst.test.redhat.com, and using the
installer_16jul02_1425.iso (latest build), I select the 'Skip Registration'
checkbox on the 'RHN Account Information' screen. I then get the 'Satellite
Application Server settings' page, which wants a e-mail and sat cert. Entering
these and clicking 'next' gives the alert message 'There was a problem entitling
the server. Check the log in /var/log/satinstall', however, no entries are made
in this file relative to this message, and clicking 'OK' on the alert simply
returns you to the 'Satellite Application Server settings' page.

Thus, selecting the 'Skip Registration' checkbox means you cannot proceed past
the 'Satellite Application Server settings' page, and so, you can't install the
Satellite. 



Comment 3 Adrian Likins 2002-07-17 20:22:53 UTC
hmmm. Yeah.

It tries to entitle the system and run up2date, which in the 
case you describe, doesnt make anysense.

"Skip RHN Registrations" seems like it can me two things.

a) Dont register me with RHN, dont entitle the satelite, dont
   run up2date, etc

b) I've already registered this machine, dont do it again.

It seems like the installer mixes these ideas currently. I'll
update the installer to be more consistently (a) since I belive
that was the original intent. 

If thats the wrong assumption, someone tell me.

Comment 4 Adrian Likins 2002-07-17 20:26:36 UTC
try the version in cvs now... (0.99.8)

Comment 5 Josef Komenda 2002-07-17 23:15:16 UTC
Fixed, Closing.


Note You need to log in before you can comment on or make changes to this bug.