Bug 690103 - Django-1.3 is available
Django-1.3 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Django (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Milner
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-23 07:12 EDT by Upstream Release Monitoring
Modified: 2011-09-30 15:12 EDT (History)
5 users (show)

See Also:
Fixed In Version: Django-1.3.1-2.fc16
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-15 17:27:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2011-03-23 07:12:37 EDT
Latest upstream release: 1.3
Current version in Fedora Rawhide: 1.2.5
URL: http://pypi.python.org/packages/source/D/Django

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Jason Tibbitts 2011-03-23 17:11:28 EDT
I did a naive update to 1.3 (change version; spectool -g *spec, fedpkg mockbuild) but it fails due to an unpackaged file (/usr/lib/python2.7/site-packages/django/conf/locale/es_MX/__init__py) which seems to be an upstream bug.

There are also a load of "File listed twice" complaints for all of the new locale files under django/contrib/* since they localized all of the contrib stuff.  I guess those should be easy to deal with.

I can probably fix all of this up for you if you like.
Comment 2 Steve Milner 2011-03-25 14:11:31 EDT
I noticed the same thing when I was updating the spec and trying a build in Koji. If you have the time go for it! :-)
Comment 3 Steve Milner 2011-03-30 21:44:42 EDT
Upstream bug: http://code.djangoproject.com/ticket/15726
Comment 4 Jason Tibbitts 2011-03-30 21:53:42 EDT
I have been poking around with a simpler way to avoid all of the "file listed twice" complaints without making the %files list huge but I've not been successful.  There seems to be no simple way to do this, though to be honest I have to wonder about the value of %lang-tagging all of the .mo files anyway.  Does the software actually cope properly if they're missing?
Comment 5 Fedora Update System 2011-03-30 23:58:55 EDT
Django-1.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/Django-1.3-1.fc14
Comment 6 Fedora Update System 2011-03-30 23:59:02 EDT
Django-1.3-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/Django-1.3-1.fc13
Comment 7 Fedora Update System 2011-03-30 23:59:09 EDT
Django-1.3-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/Django-1.3-1.fc15
Comment 8 Steve Milner 2011-03-31 00:02:47 EDT
(In reply to comment #4)
> I have been poking around with a simpler way to avoid all of the "file listed
> twice" complaints without making the %files list huge but I've not been
> successful.  There seems to be no simple way to do this, though to be honest I
> have to wonder about the value of %lang-tagging all of the .mo files anyway. 
> Does the software actually cope properly if they're missing?

Good question, I don't know -- I have not tried it without them yet :-). I submitted it as is for testing to see how it goes with the current 'file listed twice' issue.
Comment 9 Ed Marshall 2011-03-31 11:20:20 EDT
Did you really mean to push this as an update to F13 and F14? See:

http://docs.djangoproject.com/en/dev/releases/1.3/#backwards-incompatible-changes-1-3
Comment 10 Jason Tibbitts 2011-03-31 11:29:25 EDT
It was submitted to testing; I would assume that it wouldn't actually be pushed to stable.  Perhaps some negative karma would ensure that.
Comment 11 Steve Milner 2011-03-31 11:37:47 EDT
I did mean to push it as an update but your point is valid and well taken -- the security enhancement and changes could cause issues. I will only push it to stable for F15+.

I am not planning on pushing 1.3 to EL6 or older.

I've added a -1 to the F13 and F14 instances.
Comment 12 Jason Tibbitts 2011-03-31 12:01:57 EDT
Since you created the update requests, you can also simply revoke them.  Or I can do it for you.
Comment 13 Fedora Update System 2011-03-31 12:56:11 EDT
Package Django-1.3-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing Django-1.3-1.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/Django-1.3-1.fc14
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2011-04-05 16:16:02 EDT
Django-1.3-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/Django-1.3-2.fc15
Comment 15 Fedora Update System 2011-04-15 17:27:38 EDT
Django-1.3-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2011-09-10 15:17:39 EDT
Django-1.2.6-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/Django-1.2.6-2.el6
Comment 17 Fedora Update System 2011-09-10 15:17:59 EDT
Django-1.3.1-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/Django-1.3.1-2.fc15
Comment 18 Fedora Update System 2011-09-10 15:18:17 EDT
Django-1.3.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/Django-1.3.1-2.fc16
Comment 19 Fedora Update System 2011-09-10 15:18:35 EDT
Django-1.3.1-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/Django-1.3.1-2.fc14
Comment 20 Fedora Update System 2011-09-17 20:52:52 EDT
Django-1.3.1-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2011-09-28 21:36:50 EDT
Django-1.3.1-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2011-09-28 23:21:48 EDT
Django-1.2.6-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2011-09-30 15:12:38 EDT
Django-1.3.1-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.