Bug 690176 - #618 TypeError when guessing the lexer of a text that begins with a dot
Summary: #618 TypeError when guessing the lexer of a text that begins with a dot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-pygments
Version: 6.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Charalampos Stratakis
QA Contact: Jakub Heger
URL:
Whiteboard:
Depends On:
Blocks: 1356061 1373251
TreeView+ depends on / blocked
 
Reported: 2011-03-23 14:17 UTC by Michal Babej
Modified: 2017-03-21 10:06 UTC (History)
7 users (show)

Fixed In Version: python-pygments-1.1.1-2.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1413594 (view as bug list)
Environment:
Last Closed: 2017-03-21 10:06:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0650 0 normal SHIPPED_LIVE python-pygments bug fix update 2017-03-21 12:32:37 UTC

Description Michal Babej 2011-03-23 14:17:25 UTC
Description of problem:
Popped up while highlighting kernel sources:
https://bitbucket.org/birkenfeld/pygments-main/issue/618/typeerror-when-guessing-the-lexer-of-a

Version-Release number of selected component (if applicable):
python-pygments-1.1.1-1.el6.noarch

How reproducible:
Try to guess lexer for a file starting with a dot

Additional info:
Patch available in upstream

Comment 2 RHEL Program Management 2011-03-23 14:48:20 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Dave Malcolm 2011-03-23 18:40:54 UTC
Upstream patch is:
  https://bitbucket.org/birkenfeld/pygments-main/changeset/92355db12206

Comment 12 errata-xmlrpc 2017-03-21 10:06:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0650.html


Note You need to log in before you can comment on or make changes to this bug.