This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 690242 - Notfications not working
Notfications not working
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: notification-daemon (Show other bugs)
15
All Unspecified
high Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-23 12:58 EDT by Thomas Woerner
Modified: 2013-03-05 23:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-23 13:45:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Woerner 2011-03-23 12:58:03 EDT
Description of problem:
Notifications are not functional in F-15 anymore if there is no notification daemon running. Only in GNOME and KDE the notifications are shown. For all other environments there is no notification at all. Using pynotify results in a traceback if show() is called.

Version-Release number of selected component (if applicable):
libnotify-0.7.2-1.fc15

How reproducible:
Always

Steps to Reproduce:
1. Start XFCW or a Window Manager
2. notify-send Hello
  
Actual results:
Nothing

Expected results:
A notification saying "Hello".

Additional info:

Here is a python snipplet:

import pynotify
pynotify.init("foo")
n = pynotify.Notification("foo", "Hello")
n.set_urgency(pynotify.URGENCY_NORMAL)
n.show()
Comment 1 David Zeuthen 2011-03-23 13:45:51 EDT
First of all you filed this against libnotify and libnotify is just a library to speaking to a notification daemon. So I'm reassigning to notification-daemon. 

Second of all I'm closing this bug as NOTABUG, as it is simply not notification-daemon's job to start itself - that job belongs to whatever environment you are logged into. Specifically, the environment you log into may decide to implement the org.freedesktop.Notifications itself and not use notification-daemon at all. GNOME 3 is one example where notification-daemon is started only in fallback mode.

So if this doesn't work in XFCE or any other DE and you think it should, suggest to file bugs against those desktops.
Comment 2 David Zeuthen 2011-03-23 14:03:43 EDT
Btw, one change from f14 is that notification-daemon doesn't ship a D-Bus .service for activation - this was removed because it causes race conditions between different implementations. That, and because it's bad style for one implementation to position itself like that.

So that's why the non-GNOME,KDE desktops suddenly stopped "working" in f15. As explained in comment 1, the fix is simply to start notification-daemon (or any other program taking the org.freedesktop.Notificaions name and implementing the required interfaces) for the desktop in question.

Note You need to log in before you can comment on or make changes to this bug.