Bug 690461 (change_bckgrd) - [] X Crash when changing background in gnome Shell
Summary: [] X Crash when changing background in gnome Shell
Keywords:
Status: CLOSED ERRATA
Alias: change_bckgrd
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 674464 680116 680272 690083 690858 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-24 12:06 UTC by Elad Alfassa
Modified: 2018-04-11 11:26 UTC (History)
12 users (show)

Fixed In Version: xorg-x11-server-1.10.0-7.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-03 04:23:50 UTC


Attachments (Terms of Use)
xsession-errors (14.55 KB, text/plain)
2011-03-24 12:06 UTC, Elad Alfassa
no flags Details
Xorg.0.log.old after the crash (29.63 KB, text/plain)
2011-03-24 14:09 UTC, Elad Alfassa
no flags Details
Xorg.0.log.old (31.85 KB, text/plain)
2011-03-24 14:14 UTC, Elad Alfassa
no flags Details
Michel's .xsession-errors *after* first log-in after crash (8.02 KB, text/plain)
2011-03-24 14:27 UTC, Michel Alexandre Salim
no flags Details
Michel's Xorg.0.log (66.75 KB, text/x-log)
2011-03-24 14:29 UTC, Michel Alexandre Salim
no flags Details
Michel's previous Xorg.0.log (67.42 KB, application/x-trash)
2011-03-24 14:30 UTC, Michel Alexandre Salim
no flags Details
Michel's corrupted screenshot after crash (2.42 MB, image/png)
2011-03-24 14:34 UTC, Michel Alexandre Salim
no flags Details
Michel's Xorg.0.log.old (102.57 KB, application/x-trash)
2011-03-24 14:45 UTC, Michel Alexandre Salim
no flags Details
diff for .xsession-errors before and after crash (2.22 KB, text/plain)
2011-03-24 14:48 UTC, Michel Alexandre Salim
no flags Details

Description Elad Alfassa 2011-03-24 12:06:15 UTC
Created attachment 487296 [details]
xsession-errors

Description of problem:
X Crashes when changing background in gnome shell.

Version-Release number of selected component (if applicable):
gnome-shell-2.91.91-2.fc15
xorg-x11-utils-7.5-2.fc15.x86_64
xorg-x11-drv-intel-2.14.0-3.fc15.x86_64
xorg-x11-drv-hyperpen-1.3.99.1-3.20101202git0a03c1fd0.fc15.x86_64
xorg-x11-xauth-1.0.2-9.fc15.x86_64
xorg-x11-drv-acecad-1.4.99-3.20101203gitf8e87eaf4.fc15.x86_64
xorg-x11-drv-rendition-4.2.4-5.fc15.x86_64
xorg-x11-drv-glint-1.2.4-7.fc15.x86_64
xorg-x11-drv-keyboard-1.5.99.901-2.fc15.x86_64
xorg-x11-drv-trident-1.3.4-5.fc15.x86_64
xorg-x11-server-common-1.10.0-3.fc15.x86_64
xorg-x11-drv-fpit-1.3.99-3.20101206git020c04e29.fc15.x86_64
xorg-x11-drv-elographics-1.2.99-3.20101206git6fd22a9d6.fc15.x86_64
xorg-x11-drv-s3virge-1.10.4-7.fc15.x86_64
xorg-x11-server-utils-7.5-4.fc15.x86_64
xorg-x11-drivers-7.4-2.fc15.x86_64
xorg-x11-drv-nv-2.1.18-6.fc15.x86_64
xorg-x11-drv-voodoo-1.2.4-5.fc15.x86_64
xorg-x11-drv-vesa-2.3.0-7.fc15.x86_64
xorg-x11-xkb-utils-7.5-3.fc15.x86_64
xorg-x11-drv-qxl-0.0.21-2.fc15.x86_64
xorg-x11-drv-penmount-1.4.99-3.20101203git6658e9ad2.fc15.x86_64
xorg-x11-drv-sisusb-0.9.4-5.fc15.x86_64
xorg-x11-drv-ati-6.14.0-7.20110316gitcdfc007ec.fc15.x86_64
xorg-x11-drv-i740-1.3.2-7.fc15.x86_64
xorg-x11-drv-mga-1.4.13-6.fc15.x86_64
xorg-x11-drv-aiptek-1.3.99-3.20101203git95b891239.fc15.x86_64
xorg-x11-drv-wacom-0.10.99-1.20110315.fc15.x86_64
xorg-x11-font-utils-7.5-6.fc15.x86_64
xorg-x11-proto-devel-7.6-5.fc15.noarch
xorg-x11-drv-void-1.3.1-5.20101202gitcb8d19b8a.fc15.x86_64
xorg-x11-drv-vmware-11.0.3-4.fc15.x86_64
xorg-x11-drv-tdfx-1.4.3-7.fc15.x86_64
xorg-x11-drv-siliconmotion-1.7.3-8.20100122.fc15.x86_64
xorg-x11-drv-mutouch-1.2.99-4.20101206git24029451c.fc15.x86_64
xorg-x11-drv-sis-0.10.3-5.fc15.x86_64
xorg-x11-drv-cirrus-1.3.2-7.fc15.x86_64
xorg-x11-drv-fbdev-0.4.1-8.fc15.x86_64
xorg-x11-drv-openchrome-0.2.904-13.fc15.x86_64
xorg-x11-drv-nouveau-0.0.16-23.20110303git92db2bc.fc15.x86_64
xorg-x11-drv-i128-1.3.4-7.fc15.x86_64
xorg-x11-drv-apm-1.2.3-6.fc15.x86_64
xorg-x11-drv-vmmouse-12.6.99.901-3.20101209git07232feb6.fc15.x86_64
xorg-x11-server-Xorg-1.10.0-3.fc15.x86_64
xorg-x11-drv-synaptics-1.3.99.901-2.fc15.x86_64
xorg-x11-drv-evdev-2.6.0-3.fc15.x86_64
xorg-x11-drv-mach64-6.8.2-7.fc15.x86_64
xorg-x11-drv-savage-2.3.2-3.fc15.x86_64
xorg-x11-drv-mouse-1.6.99.901-2.fc15.x86_64
xorg-x11-drv-dummy-0.3.4-5.fc15.x86_64
xorg-x11-drv-v4l-0.2.0-12.fc15.x86_64
xorg-x11-xinit-1.0.9-20.fc15.x86_64
xorg-x11-drv-r128-6.8.1-9.fc15.x86_64
xorg-x11-drv-ast-0.91.10-5.fc15.x86_64

Steps to Reproduce:
1.Change background
2.Crash
  

Additional info:
See also: https://bugzilla.gnome.org/show_bug.cgi?id=645601

Comment 1 Elad Alfassa 2011-03-24 14:09:56 UTC
Created attachment 487339 [details]
Xorg.0.log.old after the crash

Comment 2 Elad Alfassa 2011-03-24 14:10:36 UTC
oops wrong file. sorry.

Comment 3 Elad Alfassa 2011-03-24 14:14:49 UTC
Created attachment 487341 [details]
Xorg.0.log.old

Now i'm sure it's the right file

Comment 4 Michel Alexandre Salim 2011-03-24 14:27:12 UTC
Created attachment 487347 [details]
Michel's .xsession-errors *after* first log-in after crash

This happens to me as well. I deleted the old .xession-errors before setting my desktop background, to make sure only the errors due to the switch are captured, and there is -- nothing. No .xsession-errors generated due to the crash.

(Sometimes the first desktop background change results in a corrupted BG but no crash; sometimes it crashes immediately)

The .xsession-errors after the first login after the crash is attached.

Comment 5 Michel Alexandre Salim 2011-03-24 14:29:12 UTC
Created attachment 487348 [details]
Michel's Xorg.0.log

My video card's an nVidia Quadro NVS 290; see Smolt for details:
http://www.smolts.org/client/show/pub_04eb447a-d09f-4dc4-9b4a-3b7dd87db43c

After the crash, after telinit 3 / telinit 5 to properly restart X, the display is still corrupted after login. Attaching screenshot after this.

Comment 6 Michel Alexandre Salim 2011-03-24 14:30:13 UTC
Created attachment 487349 [details]
Michel's previous Xorg.0.log

Comment 7 Elad Alfassa 2011-03-24 14:31:39 UTC
(In reply to comment #5)
> 
> After the crash, after telinit 3 / telinit 5 to properly restart X, the display
> is still corrupted after login. Attaching screenshot after this.
Interestingly, on my laptop X restarts automatically after the crash.

Comment 8 Michel Alexandre Salim 2011-03-24 14:34:51 UTC
Created attachment 487353 [details]
Michel's corrupted screenshot after crash

This is after switching from /usr/share/backgrounds/images/stone_bird.jpg to the default Lovelock background. Note that parts of the stone_bird.jpg can still be seen despite the background capplet showing that Lovelock is selected.

Components:
xorg-x11-server-Xorg-1.10.0-3.fc15.x86_64
xorg-x11-drv-nouveau-0.0.16-24.20110324git8378443.fc15.x86_64
mesa-dri-drivers-7.10-0.29.fc15.x86_64
kernel-2.6.35.11-83.fc14.x86_64
kernel-2.6.38-1.fc15.x86_64

(note: same problem with the latest mesa stack; downgraded to test if this is the culprit)

Comment 9 Elad Alfassa 2011-03-24 14:43:39 UTC
I don't see the same corruption on my laptop... when changing the background, it flickers a bit with black lines, then crashes, and when restarting X the background looks fine.

May be related:
using gnome-tweak-tool, when turning "Draw desktop background" off, and then on again, it results the same crash. 
When turning "Have file manager handle the desktop" on, and starting nautilus, it results the same crash.

Comment 10 Michel Alexandre Salim 2011-03-24 14:45:38 UTC
Created attachment 487356 [details]
Michel's Xorg.0.log.old

After re-upgrading mesa-* the corruption problem seems to have stopped, but changing wallpaper still reliably crashes X. Attaching the last Xorg.0.log.old file


mesa-dri-drivers-7.10.1-1.fc15.x86_64
mesa-dri-filesystem-7.10.1-1.fc15.x86_64
mesa-dri-llvmcore-7.10.1-1.fc15.x86_64
mesa-libGL-7.10.1-1.fc15.i686
mesa-libGL-7.10.1-1.fc15.x86_64
mesa-libGLU-7.10.1-1.fc15.i686
mesa-libGLU-7.10.1-1.fc15.x86_64

Comment 11 Michel Alexandre Salim 2011-03-24 14:48:08 UTC
Created attachment 487358 [details]
diff for .xsession-errors before and after crash

Deleting .xsession-errors was not a good idea because X just keeps writing to the old file handle. Here's the actual errors related to the crash.

Comment 12 Bastien Nocera 2011-03-24 21:02:03 UTC
(In reply to comment #9)
<snip>
> May be related:
> using gnome-tweak-tool, when turning "Draw desktop background" off, and then on
> again, it results the same crash. 
> When turning "Have file manager handle the desktop" on, and starting nautilus,
> it results the same crash.

The file manager and gnome-settings-daemon both use gnome-desktop to draw the background. And the code causing the crash is due to the changes in https://bugzilla.gnome.org/show_bug.cgi?id=641526.

It's still an X bug though.

Comment 13 Matěj Cepl 2011-03-25 10:44:09 UTC
*** Bug 690083 has been marked as a duplicate of this bug. ***

Comment 14 Michel Alexandre Salim 2011-03-26 09:23:42 UTC
Also happens on a Radeon 5650. I take it the problem is not hardware-related? Also, on the Radeon system, Alt-F6 (switch directly between windows of an application) brings up the black screen with the 'fail' icon, with a prompt to log out

Comment 15 Jon Dufresne 2011-03-27 15:06:03 UTC
Same issue happens here. My graphics card is a "ATI Technologies Inc Juniper [Radeon HD 5750 Series]"

Comment 16 Matěj Cepl 2011-03-29 15:55:35 UTC
*** Bug 674464 has been marked as a duplicate of this bug. ***

Comment 17 Fedora Update System 2011-03-30 20:25:53 UTC
xorg-x11-server-1.10.0-7.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.10.0-7.fc15

Comment 18 Fedora Update System 2011-03-31 03:51:53 UTC
Package xorg-x11-server-1.10.0-7.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-server-1.10.0-7.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xorg-x11-server-1.10.0-7.fc15
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2011-04-03 04:23:45 UTC
xorg-x11-server-1.10.0-7.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Matěj Cepl 2011-04-06 14:43:12 UTC
*** Bug 690858 has been marked as a duplicate of this bug. ***

Comment 21 Adam Jackson 2011-04-14 21:49:47 UTC
*** Bug 680116 has been marked as a duplicate of this bug. ***

Comment 22 Adam Jackson 2011-04-14 21:50:07 UTC
*** Bug 680272 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.