Bug 690563 - Shotwell should not BuildRequire deprecated GnomeVFS
Summary: Shotwell should not BuildRequire deprecated GnomeVFS
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: shotwell
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-24 16:35 UTC by Nicola Soranzo
Modified: 2012-04-12 02:42 UTC (History)
6 users (show)

Fixed In Version: entangle-0.3.1-2.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-12 02:42:45 UTC


Attachments (Terms of Use)

Description Nicola Soranzo 2011-03-24 16:35:45 UTC
Description of problem:
GnomeVFS has been deprecated for 3 years. Shotwell has recently started requiring gnome-vfs2 :

http://pkgs.fedoraproject.org/gitweb/?p=shotwell.git;a=commitdiff;h=217dc41649095d302b25d6a3d0b4bbb2738078f0

Moreover, this is required for HAL removal:

http://fedoraproject.org/wiki/Features/HalRemoval


Version-Release number of selected component (if applicable):

shotwell-0.8.90-2.r2758.fc16

Comment 1 Javier Jardón 2011-04-14 16:19:41 UTC
Upstream bug: http://trac.yorba.org/ticket/2987

Comment 2 Javier Jardón 2012-01-17 04:04:18 UTC
This is fixed since 0.10 now, could someone close this?

Comment 3 Nicola Soranzo 2012-01-17 10:01:35 UTC
Upstream shotwell does not require GnomeVFS anymore since 0.10, but the Fedora package still BuildRequires gnome-vfs2 in the spec file.

HAL removal has been finished anyway in the meanwhile.

Comment 4 Kalev Lember 2012-04-03 13:53:35 UTC
Thanks, removed gnome-vfs2 BuildRequires in shotwell-0.12.1-1.fc17 build.

Comment 5 Fedora Update System 2012-04-03 14:18:57 UTC
entangle-0.3.1-2.fc17,libgexiv2-0.4.1-1.fc17,shotwell-0.12.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/entangle-0.3.1-2.fc17,libgexiv2-0.4.1-1.fc17,shotwell-0.12.1-1.fc17

Comment 6 Fedora Update System 2012-04-04 21:12:09 UTC
Package entangle-0.3.1-2.fc17, libgexiv2-0.4.1-1.fc17, shotwell-0.12.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing entangle-0.3.1-2.fc17 libgexiv2-0.4.1-1.fc17 shotwell-0.12.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5320/entangle-0.3.1-2.fc17,libgexiv2-0.4.1-1.fc17,shotwell-0.12.1-1.fc17
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2012-04-12 02:42:45 UTC
entangle-0.3.1-2.fc17, libgexiv2-0.4.1-1.fc17, shotwell-0.12.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.