This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 690586 - sugar-desktop gnome-keyring-pam-2.91.93-1.fc15 (i686) does not work-pops up 11 times
sugar-desktop gnome-keyring-pam-2.91.93-1.fc15 (i686) does not work-pops up 1...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
15
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-24 13:35 EDT by satellitgo
Modified: 2015-03-03 17:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-11 09:54:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description satellitgo 2011-03-24 13:35:39 EDT
Description of problem:
Unlock Login Keyring pops up: pops up 11 times before sugar-desktop enters F3 main window. (On switching to f1 network neighborhood, wireless Access point is already connected.)


Version-Release number of selected component (if applicable):
sugar 0.92.0 Fedora release 15 (Lovelock)
gnome-keyring-pam-2.91.93-1.fc15 (i686)

How reproducible:
start sugar-desktop in sugar-emulator or from gdm switcher

Steps to Reproduce:
1.keychain to work
2.
3.
  
Actual results:
11 pop ups 

Expected results:
keychain to be accessed on first try

Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=649013   earlier duplicate?
http://bugs.sugarlabs.org/ticket/2652
Comment 1 Alexander Dalloz 2011-03-24 13:50:36 EDT
Dear reporter,

can you please provide more information in which way the tool keychain is involved?

I am not confident that keychain is even part of your setup. You write yourself about gnome-keyring-pam-2.91.93-1.fc15 and the description itself sounds as if the gnome keyring access is what misbehaves.

Else, how is your keychain configured?

Thanks

Alexander
Comment 2 satellitgo 2011-03-24 14:44:18 EDT
When I log in to gnome3 (f15), my password is required to log in by  gdm. (I assume that the keychain which is installed retains my password.) when sugar-desktop starts from (xepyr / sugar-emulator) that password seems to be not accessible, or written to, and I get 11 repeated pop-ups requesting my password even though I have entered the correct password. when the pop-ups finish, sugar desktop works normally.
Comment 3 Alexander Dalloz 2011-03-24 14:48:48 EDT
keychain is an extra tool which is not installed automatically. So please check by

rpm -q keychain

whether you really have it installed. keychain even is an opt-in tool, which means you must actively activate its use by creating a valid ~/.keychainrc. So can you please verify and post your ~/.keychainrc as well?

Thanks

Alexander
Comment 4 satellitgo 2011-03-24 15:58:10 EDT
rpm -q keychain 
package  keychain is not installed

you were right

yum install keychain
keychain.noarch 0:2.6,8-8.fc15 will be installed

terminal: keychain  
reboot
rpm -q keychain
keychain-0:2.6,8-8.fc15.noarch
start sugar-emulator
same 11 pop-ups
???
Do I need to do something else to get this fixed?
Comment 5 Alexander Dalloz 2011-03-24 16:26:37 EDT
Ok, so I understand from your last comment #4 that keychain was NOT installed. Thus it can not be the cause of your isse.

I close this ticket assigned to keychain as this is not the application giving you problems. You may reopen a ticket for a more appropriate package, which may be gnome-keyring.

Alexander
Comment 6 satellitgo 2011-03-24 17:38:53 EDT
reassigned to gnome-kering
Comment 7 Alexander Dalloz 2011-03-24 18:20:35 EDT
I am not package owner of gnome-keyring
Comment 8 Tomáš Bžatek 2011-03-25 12:46:36 EDT
So, if the Sugar session was started from Xnest/Xephyr, it's highly probable that the keyring is still locked. Due to that fact, it asks for a password, probably on every request, thus you're seeing those 11 prompts. It could be anything, most probably NetworkManager or some app that autoruns.

I admit it would be nice to show the prompt only once and block the other requests. I think I've seen a bug for that somewhere...

For hints about running gnome-keyring-daemon, please see http://live.gnome.org/GnomeKeyring/RunningDaemon
Comment 9 satellitgo 2011-03-25 13:24:05 EDT
typing # gnome-keyring-daemon --start:
** Message: couldn't access control socket? /tmp/keyring-xxxxx/control: Permission denied.
** Message: couldn't connect to dbus session bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Is there an incompatibility with sugar-emulator and the dbus?
Comment 10 Peter Robinson 2011-05-07 13:33:49 EDT
(In reply to comment #8)
> So, if the Sugar session was started from Xnest/Xephyr, it's highly probable
> that the keyring is still locked. Due to that fact, it asks for a password,
> probably on every request, thus you're seeing those 11 prompts. It could be
> anything, most probably NetworkManager or some app that autoruns.

Its telepathy-mission-control which uses it to store account information.

> I admit it would be nice to show the prompt only once and block the other
> requests. I think I've seen a bug for that somewhere...

Indeed.

> For hints about running gnome-keyring-daemon, please see
> http://live.gnome.org/GnomeKeyring/RunningDaemon

We fixed the issue on the live image by creating a default keyring with the following bash scriptlet. When we install and a new user is created this script obviously doesn't run (such as a user with liveinst). I'm not sure how other desktops create a new keyring for a user if one doesn't exist. Is that documented anywhere? It might be possible to put a default keyring in /etc/skel/

if [ ! -e /home/liveuser/.gnome2/keyrings/login.keyring ]; then
mkdir -p /home/liveuser/.gnome2/keyrings
cat >> /home/liveuser/.gnome2/keyrings/login.keyring << FOE
[keyring]
display-name=login
ctime=1302886515
mtime=1302886515
lock-on-idle=false
lock-timeout=0
FOE
chown -R liveuser:liveuser /home/liveuser/.gnome2/keyrings
fi
Comment 11 Peter Robinson 2011-06-11 09:54:13 EDT
will be fixed in sugar live image for f-15

Note You need to log in before you can comment on or make changes to this bug.