Bug 690610 - Internal error from gnatmake when compiling source code of Ahven
Summary: Internal error from gnatmake when compiling source code of Ahven
Status: CLOSED DUPLICATE of bug 613407
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc   
(Show other bugs)
Version: 14
Hardware: i386 Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-24 19:11 UTC by Tero Koskinen
Modified: 2011-06-08 22:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-08 22:50:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tero Koskinen 2011-03-24 19:11:21 UTC
Description of problem:
Compilation of Ahven (http://ahven.stronglytyped.org/) dies to assertion failure / internal error.

Version-Release number of selected component (if applicable):
gcc 4.5.1

$ gnatls -v

GNATLS 4.5.1 20100924 (Red Hat 4.5.1-4)
Copyright (C) 1997-2010, Free Software Foundation, Inc.
...
$

How reproducible:
Always.

Steps to Reproduce:
1. hg clone https://bitbucket.org/tkoskine/ahven
2. cd ahven
3. hg update -r 74620051c236
4. make
  
Actual results:
gcc -c -g -gnatf -gnatVa -gnato -gnatwe -gnatwa -gnatwl -gnatE -gnatwF -gnatyd3ibmhex -gnat95 -I- -gnatA /home/tkoskine/work/ahven/src/ahven-parameters.adb
Exception name: SYSTEM.ASSERTIONS.ASSERT_FAILURE
Message: namet.adb:616

gnatmake: INTERNAL ERROR. Please report.
make: *** [build_lib] Error 4


Expected results:
Compilation passes.

Additional info:
On Fedora 13 with gcc 4.4.4 and GNAT GPL 2010 the compilation works as expected. Only on Fedora 14 with gcc 4.5.1 the compilation fails.

The compilation also works on Debian 6.0 with gcc 4.4.5.

Comment 1 Björn Persson 2011-06-08 22:50:38 UTC

*** This bug has been marked as a duplicate of bug 613407 ***


Note You need to log in before you can comment on or make changes to this bug.