This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 690682 - RFE - As a project maintainer, I want a generic push/pull command for any project type
RFE - As a project maintainer, I want a generic push/pull command for any pro...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Maven (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sean Flanigan
Ding-Yi Chen
:
Depends On:
Blocks: zanata-1.5.0
  Show dependency treegraph
 
Reported: 2011-03-24 22:49 EDT by Sean Flanigan
Modified: 2012-03-06 19:08 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.4-SNAPSHOT
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 19:08:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2011-03-24 22:49:01 EDT
Ideally, a project maintainer should be able to run
  mvn zanata:push, mvn zanata:pull (Maven)
  zanata push, zanata pull (Python)
with no other arguments.  

Even though the push/pull command is generic, it must somehow provide options which are specific to project types (publican, gettext, Properties), whether from zanata.xml or from the command line.

We should discuss the best way of handling this configuration.

One possible solution: the generic push/pull commands have one option of their own: projectType.  (With the value of projectType coming from zanata.xml, unless overridden on the command line.)

Depending on the project type, push might be treated as an alias for publican-push, po-push, or props-push, each with its specific options.  So if projectType=publican, the push command will automatically support --srcdir, --transdir and --import-po.  And as we move some of those options into zanata.xml, they can be picked up as appropriate.

This may or may not be practical.  I think this can work in Maven, because all options come from system properties or from the generic plugin config (they're not checked against the current goal)  

Whether this will work in Python probably depends on the options-parsing and whether it can support dynamic aliasing.
Comment 1 Ding-Yi Chen 2012-02-15 20:47:47 EST
VERIFIED with zanata maven client 1.4-SNAPSHOT
Comment 2 Ding-Yi Chen 2012-02-15 20:48:54 EST
VERIFIED with zanata-python-client-1.3.3

Note You need to log in before you can comment on or make changes to this bug.