Bug 6908 - Deleting old GTK shared libraries unacceptable
Deleting old GTK shared libraries unacceptable
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Depends On:
  Show dependency treegraph
Reported: 1999-11-10 22:01 EST by whitis
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-11-11 10:34:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description whitis 1999-11-10 22:01:33 EST
Under the current system, installing gnome from RPMs is
hazardous to your health.  You won't get more than one
GNOME app to work at a time (unless they came in the
same bundle).

This bug report applies to all versions of GTK rpms - even
the old rpms need to be fixed (or a new rpm full of old
versions created).

Redhat loves to delete old versions you still need.  One
place this hurts you is
GTK shared libraries.  The shared library system is smart
enough to
handle multiple library versions simultaneously installed
and will
try to pick the closest match;  Redhat screws this up by
the old ones.  This
is why you can almost never get gnome apps to work.  Every
gnome app
typically needs a different library version (and they aren't
compatible with
other versions because the library calling conventions
stabilized, which would be fine if redhat didn't delete the
old ones).
Every time you install a new gnome app, you need to upgrade
one or
more libaries, which thanks to redhat will break all your
gnome apps.
Comment 1 Michael Fulbright 1999-11-11 10:34:59 EST
This is not a gnome-libs issue.

Installing the gtk+-1.2-xxx packages will not break existing
applications which are linked against gtk+-1.0. The gtk+10 package,
which is required in order to install the gtk+-1.2 package, has the
required shared libraries which gtk+-1.0 apps require.  The
upgrade to gtk+-1.2 unless the gtk+-1.0 package exists, or you
used --force to install, in which case the consequences are not
guaranteed to be good.

Note You need to log in before you can comment on or make changes to this bug.