Bug 69096 - i386.rpm rebuild from src.rpm has strange dependencies
Summary: i386.rpm rebuild from src.rpm has strange dependencies
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-17 20:09 UTC by Florin Andrei
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-11 21:28:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Florin Andrei 2002-07-17 20:09:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
I'm rebuilding perl from src.rpm
I only enabled threading, and changed the vendor name to SGI.
The rebuilt packages have strange dependencies:

[root@vrazalla root]# rpm -Uvh perl-5.6.1-34.99.6SGI.i386.rpm
error: failed dependencies:
        all:   is needed by perl-5.6.1-34.99.6SGI
        BEGIN   is needed by perl-5.6.1-34.99.6SGI
        /usr/local/bin/perl   is needed by perl-5.6.1-34.99.6SGI
[root@vrazalla root]#

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rebuild the src.rpm
2.install the resulting perl....i386.rpm
3.
	

Actual Results:  install fails saying... (see above)

Expected Results:  perl.....i386.rpm should install fine

Additional info: There was also a perl-related bug in rpm-build. I'll send a bug
report on that ASAP.

Comment 1 Florin Andrei 2002-07-18 18:29:18 UTC
The related Perl bug was #69098


Note You need to log in before you can comment on or make changes to this bug.