Bug 69115 - Crash when asked to create swap file on upgrade installation.
Crash when asked to create swap file on upgrade installation.
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-17 18:24 EDT by Jamie Guinan
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-17 22:16:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jamie Guinan 2002-07-17 18:24:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/0

Description of problem:
Upgrading my Vaio laptop from RH 7.2, I have one big
partition for Linux, no swap partition.  Installer
prompted to either create a swap file or not to (radio
button selection).  When I elected to create one, it
crashed.  Repeated the install without creating one,
and it went smoothly.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Selected "Upgrade existing installation".
2. In dialog where it suggests a new swap file, I selected
   the option to create the newer/bigger swap file
   (I only have one ext3 partition, no separate partition for swap).
3. Click [Next] or whatever, anaconda crashes in line 50
   of /usr/lib/anaconda/iw/upgrade_swap_gui.py, with 
   "rc not defined" or something to that effect. 
	

Actual Results:  Installer "crashed", but let me jump into Python debugger
to look at the problem.


Expected Results:  Installer should not have crashed. :)


Additional info:

Looking at /usr/lib/anaconda/iw/upgrade_swap_gui.py.
it appears that if the "if" clause on line 39 evaluates
false, rc isn't set.
Comment 1 Jeremy Katz 2002-07-18 02:14:09 EDT
Already fixed in CVS (dupe of a few others)

Note You need to log in before you can comment on or make changes to this bug.