Bug 691232 - gdm loses user name after software update
gdm loses user name after software update
Status: CLOSED DUPLICATE of bug 678236
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
15
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-27 13:33 EDT by satellitgo
Modified: 2015-01-14 18:26 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-20 12:19:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description satellitgo 2011-03-27 13:33:00 EDT
Description of problem:
gdm loses user name after software update in gnome3-shell

Version-Release number of selected component (if applicable):
gnome 2.91.93

How reproducible:


Steps to Reproduce:
1.run software update
2.restart
3.gdm forgets user name and starts with "other"
  
Actual results:
gdm forgets user name and starts with "other"

Expected results:
gdm retains user name that started update

Additional info:
This could confuse a novice user and should be fixed before release
Comment 1 Andre Robatino 2011-03-27 16:28:47 EDT
You can change the Platform to "All Linux" since this happens on x86_64 also.
Comment 2 Owen Taylor 2011-03-29 12:32:45 EDT
No obvious connection to GNOME Shell

(GNOME Shell is the component that handles the application launching and window management once you've logged into the desktop from GDM)
Comment 3 Samuel Sieb 2011-04-04 17:20:35 EDT
Is this the same as bug 678236?
Comment 4 satellitgo 2011-04-04 17:57:21 EDT
I do not think it is, though it may be related. This occurs after software update or after "new firstboot "
Entry of name of user in other results in correct login. Name appears in subsequent logins unless update is done.
Comment 5 Steve Tyler 2011-04-20 08:02:05 EDT
I just did an update and restarted. The user list showed "Other..." only.

accountsservice-0.6.9-1.fc15.i686
gdm-3.0.0-2.fc15.i686
gdm-plugin-fingerprint-3.0.0-2.fc15.i686

tail of /var/log/yum.log
(Apr 20 entries are for the update that reproduced this bug.)

Apr 18 15:21:29 Updated: 1:gdm-3.0.0-2.fc15.i686
Apr 18 15:21:29 Updated: 1:gdm-plugin-fingerprint-3.0.0-2.fc15.i686
Apr 20 03:20:19 Updated: xorg-x11-server-common-1.10.1-8.fc15.i686
Apr 20 03:20:20 Installed: gnome-js-common-0.1.2-4.fc15.noarch
Apr 20 03:20:20 Installed: lovelock-backgrounds-stripes-single-14.91.1-1.fc15.noarch
Apr 20 03:20:21 Installed: lovelock-backgrounds-stripes-gnome-14.91.1-1.fc15.noarch
Apr 20 03:20:21 Updated: adwaita-gtk2-theme-3.0.0-4.fc15.i686
Apr 20 03:20:23 Updated: adwaita-cursor-theme-3.0.0-4.fc15.noarch
Apr 20 03:20:23 Installed: desktop-backgrounds-gnome-15.0.0-8.fc15.noarch
Apr 20 03:20:33 Updated: fedora-release-notes-14.98.0-1.fc15.noarch
Apr 20 03:20:35 Updated: dracut-009-6.fc15.noarch
Apr 20 03:20:42 Updated: papyon-0.5.5-1.fc15.noarch
Apr 20 03:20:42 Updated: polkit-desktop-policy-0.101-5.fc15.noarch
Apr 20 03:20:51 Updated: gnome-user-docs-3.0.2-1.fc15.noarch
Apr 20 03:20:56 Updated: gvfs-1.8.0-2.fc15.i686
Apr 20 03:20:56 Updated: libgcc-4.6.0-5.fc15.i686
Apr 20 03:20:58 Updated: xorg-x11-server-Xorg-1.10.1-8.fc15.i686
Apr 20 03:20:59 Updated: 1:NetworkManager-glib-0.8.998-3.git20110419.fc15.i686
Apr 20 03:21:00 Updated: polkit-0.101-5.fc15.i686
Apr 20 03:21:01 Installed: seed-3.0.0-1.fc15.i686
Apr 20 03:21:03 Updated: 1:wpa_supplicant-0.7.3-6.fc15.i686
Apr 20 03:21:06 Updated: 1:NetworkManager-0.8.998-3.git20110419.fc15.i686
Apr 20 03:21:06 Updated: adwaita-gtk3-theme-3.0.0-4.fc15.i686
Apr 20 03:21:07 Updated: libfprint-0.4.0-1.fc15.i686
Apr 20 03:21:12 Installed: gnome-themes-standard-3.0.0-4.fc15.i686
Apr 20 03:21:13 Updated: fprintd-0.4.1-1.fc15.i686
Apr 20 03:21:14 Updated: fprintd-pam-0.4.1-1.fc15.i686
Apr 20 03:21:22 Updated: 1:NetworkManager-gnome-0.8.998-3.git20110419.fc15.i686
Apr 20 03:21:29 Updated: NetworkManager-openconnect-0.8.1-9.git20110419.fc15.i686
Apr 20 03:21:34 Updated: 1:gnome-games-3.0.1.1-1.fc15.i686
Apr 20 03:21:35 Updated: xorg-x11-drv-cirrus-1.3.2-8.fc15.i686
Apr 20 03:21:36 Updated: xorg-x11-drv-wacom-0.11.0-1.fc15.i686
Apr 20 03:21:36 Updated: xorg-x11-drv-synaptics-1.4.0.901-1.fc15.i686
Apr 20 03:21:37 Updated: libgomp-4.6.0-5.fc15.i686
Apr 20 03:21:38 Updated: libstdc++-4.6.0-5.fc15.i686
Apr 20 03:21:40 Updated: mtools-4.0.16-1.fc15.i686
Apr 20 03:21:41 Updated: gvfs-obexftp-1.8.0-2.fc15.i686
Apr 20 03:21:41 Updated: gvfs-smb-1.8.0-2.fc15.i686
Apr 20 03:21:42 Updated: gvfs-archive-1.8.0-2.fc15.i686
Apr 20 03:21:42 Updated: gvfs-gphoto2-1.8.0-2.fc15.i686
Apr 20 03:21:43 Updated: gvfs-fuse-1.8.0-2.fc15.i686
Apr 20 03:21:43 Updated: gvfs-afc-1.8.0-2.fc15.i686
Apr 20 03:21:44 Updated: xorg-x11-server-Xephyr-1.10.1-8.fc15.i686
Apr 20 03:21:46 Updated: orc-0.4.13-1.fc15.i686
Apr 20 03:21:55 Erased: gnome-background-standard
Comment 6 Steve Tyler 2011-04-20 08:21:22 EDT
satellit: Could you attach /var/log/yum.log and report the date of the update?
Exactly what packages were in the update might help solve this bug.
Comment 7 Steve Tyler 2011-04-20 08:31:14 EDT
(In reply to comment #5)
> I just did an update and restarted. The user list showed "Other..." only.

On a different system, I updated and restarted.
The user list showed a user name, as expected.
So updating does not seem to be a reliable reproducer.

accountsservice-0.6.9-1.fc15.x86_64
gdm-3.0.0-2.fc15.x86_64
gdm-plugin-fingerprint-3.0.0-2.fc15.x86_64
Comment 8 Andre Robatino 2011-04-20 08:41:53 EDT
Booting from the latest GNOME3 test day i686 live image, on 2 different machines, on one I got logged in automatically, on the other I end up on the gdm screen with "Other" for the username. Only booted once from each so don't know if the different behavior is reproducible on each. But clearly it doesn't just depend on the set of installed packages.

https://fedoraproject.org/wiki/Test_Day:2011-04-21_GNOME3_Final#Live_image
Comment 9 Adam Williamson 2011-04-20 12:19:06 EDT
I don't see anything to differentiate this from 678236. There's no indication the update 'causes' it (and comment #7 says it doesn't). 678236 is the bug for gdm sometimes showing no users in the list.

*** This bug has been marked as a duplicate of bug 678236 ***

Note You need to log in before you can comment on or make changes to this bug.