Bug 69137 - snmpd reports memory incorrectly.
snmpd reports memory incorrectly.
Status: CLOSED DUPLICATE of bug 67610
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-18 03:28 EDT by Ben Woodard
Modified: 2015-03-04 20:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-18 03:38:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixes the line (466 bytes, patch)
2002-07-18 03:30 EDT, Ben Woodard
no flags Details | Diff

  None (edit)
Description Ben Woodard 2002-07-18 03:28:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020606

Description of problem:
When you view the enterprises.ucdavis.memory part of the mib the values reported
are incorrect.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.snmpwalk host community memory

	

Actual Results:  [ben@xenophanes SPECS]$ snmpwalk localhost chaos memory
enterprises.ucdavis.memory.memIndex.0 = 0
enterprises.ucdavis.memory.memErrorName.0 = swap
enterprises.ucdavis.memory.memTotalSwap.0 = -1
enterprises.ucdavis.memory.memAvailSwap.0 = -1
enterprises.ucdavis.memory.memTotalReal.0 = -1
enterprises.ucdavis.memory.memAvailReal.0 = -1
enterprises.ucdavis.memory.memTotalFree.0 = -2
enterprises.ucdavis.memory.memMinimumSwap.0 = 16000
enterprises.ucdavis.memory.memShared.0 = -1
enterprises.ucdavis.memory.memBuffer.0 = -1
enterprises.ucdavis.memory.memCached.0 = -1
enterprises.ucdavis.memory.memSwapError.0 = 1
enterprises.ucdavis.memory.memSwapErrorMsg.0 = Running out of swap space (-1)


Expected Results:  [ben@xenophanes SPECS]$ snmpwalk localhost chaos memory
enterprises.ucdavis.memory.memIndex.0 = 0
enterprises.ucdavis.memory.memErrorName.0 = swap
enterprises.ucdavis.memory.memTotalSwap.0 = 522072
enterprises.ucdavis.memory.memAvailSwap.0 = 522056
enterprises.ucdavis.memory.memTotalReal.0 = 512372
enterprises.ucdavis.memory.memAvailReal.0 = 9348
enterprises.ucdavis.memory.memTotalFree.0 = 531404
enterprises.ucdavis.memory.memMinimumSwap.0 = 16000
enterprises.ucdavis.memory.memShared.0 = 8300
enterprises.ucdavis.memory.memBuffer.0 = 22216
enterprises.ucdavis.memory.memCached.0 = 274064
enterprises.ucdavis.memory.memSwapError.0 = 0
enterprises.ucdavis.memory.memSwapErrorMsg.0 = 


Additional info:
Comment 1 Ben Woodard 2002-07-18 03:30:22 EDT
Created attachment 65724 [details]
Patch that fixes the line
Comment 2 Ben Woodard 2002-07-18 03:36:52 EDT
This bug seems to be fixed in the upstream sources at least in the head of the
CVS repository.
Comment 3 Phil Knirsch 2002-07-18 03:39:04 EDT
And has been reported already twice :-)

Read ya, Phil

*** This bug has been marked as a duplicate of 67610 ***

Note You need to log in before you can comment on or make changes to this bug.