Bug 69140 - gnome-terminal shouldn't grab F1 for help
gnome-terminal shouldn't grab F1 for help
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-terminal (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-18 04:08 EDT by Jens Petersen
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-20 23:42:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2002-07-18 04:08:38 EDT
Description of Problem:
gnome-terminal now binds F1 to help starting yelp.
But with this binding F1 can't be entered into a
terminal session.

Version-Release number of selected component (if applicable):
gnome-terminal-2.0.0.90-1

How Reproducible:
Every time.

Steps to Reproduce:
1. Start gnome-terminal.
2. Press F1.

Actual Results:
yelp pops up.

Expected Results:
F1 should go to the application.

Additional Information:
I realise the Help binding can be changed with gconf,
but I think the default should be something better like say "<control>F1"(?),
since using F1 inside a terminal is rather common. Eg tty emacs, etc, etc.
Comment 1 Havoc Pennington 2002-07-21 19:41:04 EDT
F1 is the standard binding for Help though - that's what you'd use it for in
Emacs as well. ;-)

I dunno, it's easy enough to change if you use this binding in a terminal app.
It seems pretty valuable to have Help on the standard keybinding instead of
something weird (though I already used something weird for e.g. copy/paste).
Comment 2 Jens Petersen 2002-07-24 08:02:50 EDT
How about using Ctrl-Shift-F1 for help too, like for the cut'n'paste bindings
too.  Terminal are rather special apps, in that their own keybindings should be
as unobtrusive as possible.  I wonder too how many gnome-terminal users
actually need to look at the help documentation.

Note You need to log in before you can comment on or make changes to this bug.