Bug 691483 - [RFE] rebase augeas in RHEL
Summary: [RFE] rebase augeas in RHEL
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: augeas
Version: 6.2
Hardware: All
OS: All
high
high
Target Milestone: rc
: ---
Assignee: David Lutterkort
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords: FutureFeature, Rebase
: 696271 (view as bug list)
Depends On:
Blocks: 607248 659725 699280 638197
TreeView+ depends on / blocked
 
Reported: 2011-03-28 16:40 UTC by Jeremy Eder
Modified: 2018-11-14 13:32 UTC (History)
20 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-12-06 16:37:45 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1659 normal SHIPPED_LIVE augeas bug fix and enhancement update 2011-12-06 00:50:22 UTC

Comment 5 Laine Stump 2011-03-31 17:30:28 UTC
augeas is used by netcf, but the netcf versions in all Fedora releases and RHEL are identical, and the Fedoras are already using augeas-0.8.0, so there should be no problems with netcf.

Comment 6 Erinn Looney-Triggs 2011-04-04 22:16:48 UTC
Case 00446661 filed with the same request.

Comment 10 J.H.M. Dassen (Ray) 2011-04-13 16:22:32 UTC
   2. What is the nature and description of the request?

Customer would like a rebase of augeas package in RHEL6

   3. Why does the customer need this? (List the business requirements here)

It is a matter of automation, there are a large number of lenses added in
later augeas releases that allow easier scale and automation for our
systems. The more we can automate the less it costs. Couple this with the
fact that debugging output is broken in this version of augeas and for all
intent and purposes there isn't a great deal of utility in this particular
version of augeas. It is unable to parse EFI based grub entries,
/letc/login.defs, or a fair number of other files thus restricting our
ability to automate.

   4. How would the customer like to achieve this? (List the functional
requirements here)

Customer want to see Augeas 0.8.0 or higher available in rhel 6 channel 

   5. For each functional requirement listed in question 4, specify how Red
Hat and the customer can test to confirm the requirement is successfully
implemented.

He should be able to install Augeas 0.8.0 or higher in rhel 6 machine.

   6. Is there already an existing RFE upstream or in Red Hat bugzilla?

Yes, https://bugzilla.redhat.com/show_bug.cgi?id=691483

   7. How quickly does this need resolved? (desired target release)

minor release 

   8. Does this request meet the RHEL Inclusion criteria (please review)

yes

   9. List the affected packages

augeas

  10. Would the customer be able to assist in testing this functionality if implemented?

Yes

Comment 12 Denise Dumas 2011-04-13 16:30:34 UTC
This has missed the RHEL 6.1 window for rebases. Moving to 6.2, but with plan to get it into 6.2 early.

Comment 15 Siddharth Nagar 2011-06-13 01:33:44 UTC
*** Bug 696271 has been marked as a duplicate of this bug. ***

Comment 18 David Lutterkort 2011-07-26 17:32:21 UTC
Built augeas-0.9.0-1.el6 in brew

Comment 24 errata-xmlrpc 2011-12-06 16:37:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1659.html


Note You need to log in before you can comment on or make changes to this bug.