Bug 691489 - preupgrade no longer possible if /boot < 200MB
preupgrade no longer possible if /boot < 200MB
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
14
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-28 13:00 EDT by Stefan Becker
Modified: 2011-05-15 03:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-15 03:02:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Becker 2011-03-28 13:00:45 EDT
Description of problem:

Due to anaconda changes (installer stage2 merged into initrd.img), preupgrade fails on /boot < 200MB. 128MB was a common /boot size in older Fedora installations.

preupgrade should offer the option to

   a) generate a USB boot stick, or

   b) copy the files to an alternative directory with the correct grub entry, so that power users can copy it to their own USB sticks.

Version-Release number of selected component (if applicable):
preupgrade-1.1.8-1.fc4

How reproducible:
Always

Additional info:
I mounted another partition on /boot/upgrade, so that preupgrade continued. Afterwards I moved those files to my USB stick. But the boot is unsuccessful as root can't be found. My guess is that some option is required to tell the initrd that it is BOOTED from the USB stick but should INSTALL on the internal hard-drive. (root= doesn't do this, BTW)
Comment 1 Richard Hughes 2011-03-29 03:54:04 EDT
I don't think the small boot problem is much of a problem for most people. In the current version of preupgrade we just tell the user to use the dvd if there is such a tiny /boot filesystem. That said, if you come up with a patch for preupgrade to use a usb device, I'll happily review it.

Note You need to log in before you can comment on or make changes to this bug.