Bug 691554 - autosubscribe appears to fail on ppc64 client when all generated product certs from TESTDATA are on client
autosubscribe appears to fail on ppc64 client when all generated product cert...
Status: CLOSED CURRENTRELEASE
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.5
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-03-28 15:55 EDT by John Sefler
Modified: 2015-05-14 11:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 09:04:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-03-28 15:55:11 EDT
Description of problem:
While testing on a ppc64 client with 4 sockets pointed to an onpremises candlepin with TESTDATA imported, I've come across this case where autosubscribe fails to bind to the installed product (37062.pem - Awesome OS Premium Architecture Bits) when all of the other generated product certs are also installed.  Strangely however, when I remove the other generated product certs, autosubscribe successfully binds to the installed product (37062.pem - Awesome OS Premium Architecture Bits) as I expect it to.



Version-Release number of selected component (if applicable):
[root@jsefler-f14-candlepin candlepin]# git branch
* 0.2
  master
[root@jsefler-f14-candlepin candlepin]# git show-ref 0.2
ec4483b30f144aca8fafc074d6adddd213b1e485 refs/heads/0.2
9c13d6bf6d83070bbc78638f6ca3bc1dc5267977 refs/remotes/origin/0.2

[root@ibm-js22-08 product1]# rpm -qa | grep subscription-manager
subscription-manager-0.95.5-1.el6.ppc64


How reproducible:


Steps to Reproduce:
1. deploy your own onpremises candlepin server from branch 0.2 with TESTDATA

2. checkout a ppc64 4-socket client from beaker (https://beaker.engineering.redhat.com)

3. configure your client's rhsm.conf to point to your onpremises candlepin server

4. copy ONLY the generated product certs for "Awesome OS Premium Architecture Bits" from your onpremises candlepin server candlepin/proxy/generated_certs/37062.pem to your client's /etc/pki/product directory.

5. register and list available looking for awesomeos-ppc-16-socket-std
[root@ibm-js22-08 ~]# subscription-manager  list --avail | grep awesomeos-ppc -B1 -A3
                        Standard Support)
ProductId:         	awesomeos-ppc-16-socket-std
PoolId:            	8a90f8b42efaa2be012efaa358460151
Quantity:          	10                       
Expires:           	2012-03-26               
--
                        Standard Support)
ProductId:         	awesomeos-ppc-16-socket-std
PoolId:            	8a90f8b42efaa2be012efaa3586c0155
Quantity:          	5                        
Expires:           	2012-03-26  
  
6. autosubscribe
[root@ibm-js22-08 ~]# subscription-manager subscribe --auto
Installed Products:
   Awesome OS Server Bits - Not Installed
   Awesome OS Premium Architecture Bits - Subscribed
   Red Hat Enterprise Linux 6 for Premium Architectures - Not Subscribed

VERIFIED^^^ These autosubscribe results looks correct. The "Awesome OS Premium Architecture Bits" is Subscribed using the subscription for awesomeos-ppc-16-socket-std as expected.

7. now unsubscribe all to get back to a clean state
[root@ibm-js22-08 ~]# subscription-manager  unsubscribe --all

8. copy ALL of the generated product certs from your on premises candlepin server candlepin/proxy/generated_certs/*.pem to your client's /etc/pki/product directory.

9. autosubscribe
[root@ibm-js22-08 ~]# subscription-manager subscribe --auto
Installed Products:
   Awesome OS Workstation Bits - Subscribed
   Awesome OS Server Bits - Subscribed
   Management Bits - Subscribed
   Shared Storage Bits - Subscribed
   Large File Support Bits - Subscribed
   Clustering Bits - Subscribed
   Load Balancing Bits - Subscribed
   Awesome OS Modifier Bits - Subscribed
   Awesome OS Scalable Filesystem Bits - Subscribed
   Red Hat Enterprise Linux 6 for Premium Architectures - Not Subscribed
   Awesome OS Developer Basic - Not Subscribed
   Awesome OS for S390X Bits - Not Subscribed
   Awesome OS Developer Bits - Not Subscribed
   Multiplier Product Bits - Not Subscribed
   Awesome OS Premium Architecture Bits - Not Subscribed

FAILED! ^^^ "Awesome OS Premium Architecture Bits" is installed, but NOT auto-SUBSCRIBED.

Because the product cert for "Awesome OS Premium Architecture Bits" is installed and is a providedProduct from the available awesomeos-ppc-16-socket-std subscription pool, then I expected it to be autosubscribed no matter what other product certs are on the box.


Additional info:
This was detected from an automated test run of SubscribeTests.VerifyInstalledProductCertWasAutoSubscribed_Test with
Method arguments: productName='Awesome OS Premium Architecture Bits' serialNumber='1215846696' id='37062' issuer='CN=jsefler-f14-beakerpin.usersys.redhat.com, C=US' validityNotBefore='Mar 28 00:30:50 2011 EDT' validityNotAfter='Mar 28 00:30:50 2021 EDT' 
on a ppc64 client.
Comment 1 John Sefler 2011-10-21 23:50:46 EDT
I believe there is still a problem here.  Opening bug 748113 which is a more simplified version of this bug.
Comment 2 Bryan Kearney 2012-07-17 09:04:39 EDT
Marking all community bugs modified or beyong as closed.

Note You need to log in before you can comment on or make changes to this bug.