Bug 691564 - BFO files don't appear to support (U)EFI hardware.
BFO files don't appear to support (U)EFI hardware.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gpxe (Show other bugs)
15
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-28 16:26 EDT by Chris Murphy
Modified: 2013-01-09 18:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 18:21:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Murphy 2011-03-28 16:26:02 EDT
Description of problem: http://boot.fedoraproject.org/ provides no useful information on whether the files support UEFI booting, and if not, references to how to make it work.


Version-Release number of selected component (if applicable): Fedora 14 and Fedora 15.


How reproducible: 100%


Steps to Reproduce:
1. Download bfo.usb from http://boot.fedoraproject.org/
2. dd the image to a USB stick.
3. Attempt to boot.
  
Actual results:
(U)EFI machines don't show the USB stick as being bootable. BIOS machines do.


Expected results:
Expect either a separate BFO file to download for use with UEFI hardware, or for the existing ones to support booting UEFI hardware.


Additional info:
http://fedoraproject.org/wiki/QA:Testcase_UEFI_pxeboot

There appears to be no valid *.efi files at http://serverbeach1.fedoraproject.org/pub/alt/bfo/. So it doesn't appear possible on the remote side, even if the local hardware is capable.
Comment 1 Fedora Admin XMLRPC Client 2011-04-04 16:37:44 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Daniel Berrange 2012-03-19 18:21:54 EDT
Unfortunately this is not the right place for this kind of request. You need to file a ticket with the Fedora Infrastructure team:

https://fedorahosted.org/fedora-infrastructure/
Comment 3 Chris Murphy 2012-03-19 18:39:51 EDT
You mean this is a feature request and not a bug? I'm not quite understanding. If BFO is a good idea for BIOS machines, it seems it would also be a good idea for UEFI machines. And I understand the USB stick contents would be considerably different because the only local files BFO provides is the bootloader - and that's what's so radically different between BIOS and UEFI.

So if it's a feature request, would I basically be asking for UEFI equivalent BFO files be produced?

Note You need to log in before you can comment on or make changes to this bug.