Bug 69177 - Use of #!/usr/bin/python considered harmful
Use of #!/usr/bin/python considered harmful
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: python (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-18 13:38 EDT by Need Real Name
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-18 13:38:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-18 13:38:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020606

Description of problem:
Many RH utilities require a particular version of Python.  The problem is that
these utilities use #!/usr/bin/python as the shebang line.  This creates
problems for users who wish to install their own version of Python.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Python 2.2 rpm from www.python.org
2. Type "python" at prompt
3. See Python 1.5.2 start (rpm's install Python 2.x as "python2").
	

Expected Results:  The simple solution is for RH to use #!/usr/bin/python-1.5.2,
#!/usr/bin/python-rh or something similar to avoid conflicts with user-installed
versions of Python.  Please don't let this issue live on into RH 8.0.

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-08-13 17:29:56 EDT
Most don't require a specific version of python, if you had the proper modules
installed they'd continue to work...
Comment 2 Need Real Name 2002-12-02 23:00:51 EST
Recently switched to Redhat 8.0 which comes with python 2.1.  Some new features of Python 2.2 are needed so I decide to upgrade.  However, since this is NOTABUG, I'll be stuck in rpm-hell.  I suppose it would be just as easy to switch to Gentoo Linux.  It's just too bad that I actually spent $$$ on Redhat (which won't happen again if this nonsense continues).  Thanks a ton for listening to the community (and no, it isn't just me: check the archives for comp.lang.python where RedHat's retarded stance on this issue has been discussed several times).


[root@software1 python]# rpm -hUv python2-2.2-2.i386.rpm
error: Failed dependencies:
        libdb-3.2.so is needed by python2-2.2-2
        Distutils is needed by (installed) 4Suite-0.11.1-10
        python is needed by (installed) libxml2-python-2.4.23-1
        python >= 2.2 is needed by (installed) rpm404-python-4.0.4-8x.27
        python is needed by (installed) redhat-config-packages-1.0.1-1
        python is needed by (installed) python-optik-1.3-2
        python is needed by (installed) rhnlib-1.0-1
        python >= 2.2 is needed by (installed) rpm-python-4.1-1.06
        python >= 2.2 is needed by (installed) up2date-3.0.7-1
        python is needed by (installed) PyXML-0.7.1-6
        python is needed by (installed) 4Suite-0.11.1-10
        python is needed by (installed) redhat-config-network-1.1.20-1
        python is needed by (installed) redhat-config-printer-0.4.24-1
        python >= 2.2 is needed by (installed) redhat-switch-printer-0.5.12-1
        python >= 2.2 is needed by (installed) redhat-switch-printer-gnome-0.5.12-1
        python >= 2.2 is needed by (installed) redhat-switchmail-0.5.14-1
        python >= 2.2 is needed by (installed) redhat-switchmail-gnome-0.5.14-1
        python >= 1.5.2-27 is needed by (installed) rhn-applet-2.0.0-28
        python is needed by (installed) firstboot-1.0.1-10
        python = 2.2.1 is needed by (installed) sip-3.3.2-4
        python >= 2.2.1 is needed by (installed) PyQt-3.3.2-4
        /usr/bin/python is needed by (installed) libxml2-python-2.4.23-1
        /usr/bin/python is needed by (installed) redhat-config-kickstart-2.3.3-3
        /usr/bin/python is needed by (installed) up2date-3.0.7-1
        /usr/bin/python is needed by (installed) gettext-0.11.4-3
        /usr/bin/python is needed by (installed) alchemist-1.0.24-4
        /usr/bin/python is needed by (installed) PyXML-0.7.1-6
        /usr/bin/python is needed by (installed) 4Suite-0.11.1-10
        /usr/bin/python is needed by (installed) redhat-config-network-1.1.20-1
        /usr/bin/python is needed by (installed) redhat-config-printer-0.4.24-1
        /usr/bin/python is needed by (installed) redhat-config-printer-gui-0.4.24-1
        /usr/bin/python is needed by (installed) up2date-gnome-3.0.7-1
        /usr/bin/python is needed by (installed) rhn-applet-2.0.0-28
        /usr/bin/python is needed by (installed) libglade2-devel-2.0.0-2
        /usr/bin/python is needed by (installed) kdelibs-3.0.3-8
        /usr/bin/python is needed by (installed) kdesdk-kbabel-3.0.3-2
        /usr/bin/python2.2 is needed by (installed) comps-extras-8.0-3
        /usr/bin/python2.2 is needed by (installed) authconfig-gtk-4.2.12-3
        /usr/bin/python2.2 is needed by (installed) redhat-config-language-1.0.1-6
        /usr/bin/python2.2 is needed by (installed) redhat-config-rootpassword-1.0.1-1
        /usr/bin/python2.2 is needed by (installed) redhat-config-users-1.1.1-2
        /usr/bin/python2.2 is needed by (installed) redhat-logviewer-0.8.3-2
        /usr/bin/python2.2 is needed by (installed) rhpl-0.51-1
        /usr/bin/python2.2 is needed by (installed) redhat-config-date-1.5.2-10
        /usr/bin/python2.2 is needed by (installed) redhat-config-keyboard-1.0.1-1
        /usr/bin/python2.2 is needed by (installed) redhat-config-kickstart-2.3.3-3
        /usr/bin/python2.2 is needed by (installed) redhat-config-mouse-1.0.1-2
        /usr/bin/python2.2 is needed by (installed) redhat-config-soundcard-1.0.1-2
        /usr/bin/python2.2 is needed by (installed) redhat-config-network-1.1.20-1
        /usr/bin/python2.2 is needed by (installed) redhat-config-securitylevel-1.0.1-1
        /usr/bin/python2.2 is needed by (installed) firstboot-1.0.1-10

Note You need to log in before you can comment on or make changes to this bug.