Bug 691775 - [abrt] java-1.6.0-openjdk-1.6.0.0-1.39.1.9.7.el6: os::abort: Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
[abrt] java-1.6.0-openjdk-1.6.0.0-1.39.1.9.7.el6: os::abort: Process /usr/lib...
Status: CLOSED DUPLICATE of bug 692686
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.6.0-openjdk (Show other bugs)
6.1
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Deepak Bhole
BaseOS QE - Apps
abrt_hash:e4c24aabe5b413ce3bd8bd0499b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-29 09:04 EDT by Mike Khusid
Modified: 2013-04-02 19:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-04 22:48:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (83.86 KB, text/plain)
2011-03-29 09:05 EDT, Mike Khusid
no flags Details

  None (edit)
Description Mike Khusid 2011-03-29 09:04:36 EDT
abrt version: 1.1.16
architecture: x86_64
Attached file: backtrace, 85874 bytes
cmdline: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/../../bin/java sun.applet.PluginMain /tmp/icedteaplugin-mkhusid/17941-icedteanp-plugin-to-appletviewer /tmp/icedteaplugin-mkhusid/17941-icedteanp-appletviewer-to-plugin
component: java-1.6.0-openjdk
Attached file: coredump, 241913856 bytes
crash_function: os::abort
executable: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java
kernel: 2.6.32-122.el6.x86_64
package: java-1.6.0-openjdk-1.6.0.0-1.39.1.9.7.el6
rating: 3
reason: Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
release: Red Hat Enterprise Linux Workstation release 6.1 Beta (Santiago)
Attached file: sosreport.tar.xz, 1732376 bytes
time: 1301403528
uid: 500

How to reproduce
-----
Reproducing bug #612467
Comment 1 Mike Khusid 2011-03-29 09:05:07 EDT
Created attachment 488434 [details]
File: backtrace
Comment 7 Mike Khusid 2011-03-29 11:39:33 EDT
More info.

[mkhusid@mkhusid ~]$ java -version
java version "1.6.0_20"
OpenJDK Runtime Environment (IcedTea6 1.9.7) (rhel-1.39.1.9.7.el6-x86_64)
OpenJDK 64-Bit Server VM (build 19.0-b09, mixed mode)
[mkhusid@mkhusid ~]$ sudo alternatives --display libjavaplugin.so.x86_64
libjavaplugin.so.x86_64 - status is manual.
 link currently points to /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so
/usr/lib/jvm/jre-1.6.0-openjdk.x86_64/lib/amd64/IcedTeaPlugin.so - priority 16000
 slave javaws: /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/bin/javaws
 slave javaws.1: /usr/lib/jvm/jre-1.6.0-openjdk.x86_64/man/man1/javaws.1
/usr/java/jre1.6.0_24/lib/amd64/libnpjp2.so - priority 32000
 slave javaws: (null)
 slave javaws.1: (null)
Current `best' version is /usr/java/jre1.6.0_24/lib/amd64/libnpjp2.so.
[mkhusid@mkhusid ~]$ firefox --no-remote -ProfileManager

/* open http://www.java.com/en/download/testjava.jsp */

java version "1.6.0_20"
OpenJDK Runtime Environment (IcedTea6 1.9.7) (rhel-1.39.1.9.7.el6-x86_64)
OpenJDK 64-Bit Server VM (build 19.0-b09, mixed mode)
Your Java configuration is as follows:<br/> <br/>Vendor: <b><a href="http://java.com">Sun Microsystems Inc.</a></b><br/>Version: <b>Java SE 6 Update 20</b><br/>Operating System: <b>Linux 2.6.32-122.el6.x86_64</b><br/>Architecture:  <b>amd64</b>
Your Java configuration is as follows:<br/> <br/>Vendor: <b><a href="http://java.com">Sun Microsystems Inc.</a></b><br/>Version: <b>Java SE 6 Update 20</b><br/>Operating System: <b>Linux 2.6.32-122.el6.x86_64</b><br/>Architecture:  <b>amd64</b>
Obj:1.6.0_24
Exit worker loop
Obj:1.6.0_24
Exit worker loop
Exception in thread "TimerQueue" java.lang.IllegalMonitorStateException
	at java.util.concurrent.locks.ReentrantLock$Sync.tryRelease(ReentrantLock.java:155)
	at java.util.concurrent.locks.AbstractQueuedSynchronizer.release(AbstractQueuedSynchronizer.java:1262)
	at java.util.concurrent.locks.ReentrantLock.unlock(ReentrantLock.java:459)
	at java.util.concurrent.DelayQueue.take(DelayQueue.java:205)
	at javax.swing.TimerQueue.run(TimerQueue.java:167)
	at java.lang.Thread.run(Thread.java:636)
JDownload version 2009.03.03

/* open http://www.webex.com/lp/jointest/ */

Java version: 1.6.0_20
Java home: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre
OS name: Linux
OS arch: amd64
OS version: 2.6.32-122.el6.x86_64
[JDownload] Java Client Service home:https://join-test.webex.com/client/T27L/javaclient/webex/
[JDownload] Production home: /home/mkhusid/.webex/924
[MySystem version 2009.02.05.01]InitSystem ... 
###1 Runtime total memory: 160956416, free memory: 148254352
###2 Runtime total memory: 162136064, free memory: 156121920
###### try to load class DBR in MyCloassLoader2...
Loading native DBR...
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x0000003fcaf3161c, pid=24121, tid=140626765190912
#
# JRE version: 6.0_20-b20
# Java VM: OpenJDK 64-Bit Server VM (19.0-b09 mixed mode linux-amd64 compressed oops)
# Derivative: IcedTea6 1.9.7
# Distribution: Red Hat Enterprise Linux Server release 6.0 (Santiago), package rhel-1.39.1.9.7.el6-x86_64
# Problematic frame:
# C  [libc.so.6+0x13161c]
#
# An error report file with more information is saved as:
# /home/mkhusid/hs_err_pid24121.log
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Comment 15 RHEL Product and Program Management 2011-04-03 22:13:49 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 16 Deepak Bhole 2011-04-04 22:48:12 EDT

*** This bug has been marked as a duplicate of bug 692686 ***

Note You need to log in before you can comment on or make changes to this bug.