Bug 69183 - RFE: skip past filesystem setup screens on live system chroot installs
RFE: skip past filesystem setup screens on live system chroot installs
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-18 14:09 EDT by Matthew R. MacIntyre
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-12 11:16:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to skip filesystem setup on live system chroot installs (1.17 KB, patch)
2002-07-18 14:10 EDT, Matthew R. MacIntyre
no flags Details | Diff

  None (edit)
Description Matthew R. MacIntyre 2002-07-18 14:09:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020509

Description of problem:
When I was installing redhat on a live system from the command-line, various
screens dealing with filesystem and bootloader setup appear, which don't really
apply to this sort of install.  I'm not sure if performing these steps screws up
the already-installed redhat (I haven't rebooted yet to see), but they can be
bypassed in the first place.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
I was installing redhat using this command:

/usr/sbin/anaconda \
        --rootpath=/usr/src/pipfield/darnay/chroot/i386 \
        --text \
        --method=nfs:/usr/src/pipfield/darnay/ks/i386

The various install screens about hard drives, which partitioning method I'd
like to use, etc, appear.


Expected Results:  These screens should be bypassed.

Additional info:

I have created a patch for the anaconda-7.3 srpm which fixes this issue.  A
number of screens which don't apply are skipped, and no new problems arise for
me when using it.  I will append as an attachment.
Comment 1 Matthew R. MacIntyre 2002-07-18 14:10:09 EDT
Created attachment 65845 [details]
patch to skip filesystem setup on live system chroot installs
Comment 2 Matthew R. MacIntyre 2002-07-21 08:01:16 EDT
I rebooted the system that I was using anaconda with, and before I used the
patch, the partition information on the boot disk was completely destroyed. 
Grub failed with an error 22, "no such partition".  I had to boot off of a
rescue cd and re-create the partition information.

I've increased the severity of this bug to high because of the loss of data that
could potentially cause big problems for others who might try this.
Comment 3 Jeremy Katz 2002-07-29 00:44:36 EDT
This is not at all a supported path for using anaconda as it exists mainly for
the purposes of testing the installer.  Unfortunately, it is too late in the
cycle to make changes of this magnitude so I'm deferring to a future release. 
FWIW, though, I've never had this problem when running in rootpath mode myself

Note You need to log in before you can comment on or make changes to this bug.