Bug 691850 - misprocessing of invalid PID argument for ksh built-in kill
Summary: misprocessing of invalid PID argument for ksh built-in kill
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ksh
Version: 5.4
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Michal Hlavinka
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-29 16:27 UTC by Kevin Logan
Modified: 2013-11-12 14:02 UTC (History)
4 users (show)

Fixed In Version: ksh-20100621-1.el5
Doc Type: Bug Fix
Doc Text:
kill builtin did not handle extra large numbers and just reported -1 internally. This value was interpreted as -1 option thus ksh killed all user processes. This updated version has improved handling of pid conversion errors. When too big number is used, it reports error correctly.
Clone Of:
: 701890 (view as bug list)
Environment:
Last Closed: 2012-02-21 05:50:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch to fix this (1.55 KB, patch)
2011-05-04 08:15 UTC, Michal Hlavinka
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0159 normal SHIPPED_LIVE ksh bug fix and enhancement update 2012-02-20 14:53:47 UTC

Description Kevin Logan 2011-03-29 16:27:53 UTC
Description of problem: When the ksh built-in kill is called with a very large, non-existent PID value, it's treated like -1 (kill all processes owned by the user).

Version-Release number of selected component (if applicable): 20080202-14.el5

How reproducible: Every time

Steps to Reproduce:
1.Start a ksh session
2.Run a command like "kill 11269117401228512356"
  
Actual results:  All processes owned by the user are killed, like the -1 argument would normally do.

Expected results: 
error message - "kill: 11269117401228512356: no such process"

Additional info:  We encountered this when a user was trying to kill a series of processes.  The user mis-entered the process list without separating spaces.

Comment 1 Michal Hlavinka 2011-05-04 08:12:19 UTC
reproducible

Comment 2 Michal Hlavinka 2011-05-04 08:15:26 UTC
Created attachment 496723 [details]
patch to fix this

Comment 5 Michal Hlavinka 2012-01-23 14:06:42 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
kill builtin did not handle extra large numbers and just reported -1 internally. This value was interpreted as -1 option thus ksh killed all user processes. This updated version has improved handling of pid conversion errors. When too big number is used, it reports error correctly.

Comment 6 errata-xmlrpc 2012-02-21 05:50:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0159.html


Note You need to log in before you can comment on or make changes to this bug.