Bug 69194 - Bash pipe character works weirdly
Bash pipe character works weirdly
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: bash (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-18 15:44 EDT by Petri Koistinen
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 13:33:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petri Koistinen 2002-07-18 15:44:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020701

Description of problem:
Bash works diffrently depending on whitespace.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
[petri@dsl-hkigw4l83 petri]$ rpm -qa | grep vorbis
bash:  grep: command not found
[petri@dsl-hkigw4l83 petri]$ rpm -qa |grep vorbis
libvorbis-1.0rc3-4


Additional info:

bash-2.05a-16
Comment 1 Bill Nottingham 2002-07-20 23:52:19 EDT
What locale are you running in? This works for me.
Comment 2 Petri Koistinen 2002-08-16 06:21:37 EDT
[petri@dsl-hkigw4l83 petri]$ locale
LANG=fi_FI@euro
LC_CTYPE="fi_FI@euro"
LC_NUMERIC="fi_FI@euro"
LC_TIME="fi_FI@euro"
LC_COLLATE="fi_FI@euro"
LC_MONETARY="fi_FI@euro"
LC_MESSAGES="fi_FI@euro"
LC_PAPER="fi_FI@euro"
LC_NAME="fi_FI@euro"
LC_ADDRESS="fi_FI@euro"
LC_TELEPHONE="fi_FI@euro"
LC_MEASUREMENT="fi_FI@euro"
LC_IDENTIFICATION="fi_FI@euro"
LC_ALL=
[petri@dsl-hkigw4l83 petri]$
Comment 3 Petri Koistinen 2002-08-16 06:23:42 EDT
I should correct "How reproducible:" field to perhaps "sometimes." I cannot
repeat this always but I have seen this behaviour many times.
Comment 4 Tim Waugh 2002-08-21 04:35:48 EDT
Are you perhaps pressing 'shift-space' by accident? 
 
Can you get this to happen inside a 'script' session?  If so, the resulting 
typescript would be interesting to look at.
Comment 5 Tim Waugh 2002-08-22 07:12:14 EDT
Think I see what's going on: you have: 
 
rpm -qa |*grep vorbis 
 
where '*' is a UTF-8 character that looks just like a space. 
 
For example, AltGr+Shift+6 produces such a character.
Comment 6 Petri T. Koistinen 2002-08-31 14:50:47 EDT
Yeah, maybe that is the the problem. I can delete this 'magic' character with
backspace. The problem with this is:

a) I don't how can I manage to always type that invisible character.
b) Why on earth there must other invisible characters than space! ;)

Space must be the only invisible character, others must always print some trash.
This would make people's life lots of easier.

Note You need to log in before you can comment on or make changes to this bug.