Bug 691963 - Unable to log in to translate.jboss.org with Firefox 4.0
Unable to log in to translate.jboss.org with Firefox 4.0
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.2
Unspecified Unspecified
unspecified Severity unspecified
: Sprint-22
: ---
Assigned To: Sean Flanigan
Ding-Yi Chen
https://translate.jboss.org/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-29 21:17 EDT by Sean Flanigan
Modified: 2013-06-07 09:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-28 03:25:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBSEAM-4701 Major Closed Cookie path being set to empty string via getRequestContextPath forming invalid cookies in IE 2013-06-10 22:14:48 EDT

  None (edit)
Description Sean Flanigan 2011-03-29 21:17:05 EDT
Description of problem:
The form-based login at translate.jboss.org fails with "Unexpected error. Please try again." when using Firefox 4.0 (or IE, unknown version)

Version-Release number of selected component (if applicable):
1.2

How reproducible:
Every time

Steps to Reproduce:
1. Click Sign In link
2. Enter any values in the login form
3. Click Sign In button
  
Actual results:
Unexpected error. Please try again.

Expected results:
Logged in, or login failed.

Additional info:
server.log shows this error:

org.jboss.seam.ui.UnauthorizedCommandException: viewId:
/account/login_input.xhtml - No client identifier provided

This affects all forms, not just login, and appears to be caused by https://issues.jboss.org/browse/JBSEAM-4701
Comment 1 Sean Flanigan 2011-03-29 23:37:12 EDT
Note: this only affects instances which use the root context, for instance http://example.com/ , not http://example.com/zanata/ .

The workaround for this is in hg revision 308585893eab.
Comment 2 Ding-Yi Chen 2011-10-17 23:52:10 EDT
VERIFIED with Zanata version 1.4.1 (20111006-0937)
Comment 3 JBoss JIRA Server 2012-10-02 08:54:38 EDT
Marek Novotny <mnovotny@redhat.com> updated the status of jira JBSEAM-4701 to Resolved
Comment 4 JBoss JIRA Server 2012-10-02 08:54:38 EDT
Marek Novotny <mnovotny@redhat.com> made a comment on jira JBSEAM-4701

added forgotten lines from patch
Comment 5 JBoss JIRA Server 2013-06-07 09:54:57 EDT
Marek Novotny <mnovotny@redhat.com> updated the status of jira JBSEAM-4701 to Closed
Comment 6 JBoss JIRA Server 2013-06-07 09:54:57 EDT
Marek Novotny <mnovotny@redhat.com> made a comment on jira JBSEAM-4701

2.3.1.CR1 is now out, so closing all resolved issues

Note You need to log in before you can comment on or make changes to this bug.