Bug 692016 - NotifyClamd: Can't find or parse configuration file /etc/clamd.conf
Summary: NotifyClamd: Can't find or parse configuration file /etc/clamd.conf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: clamav
Version: el5
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Steven Pritchard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-30 08:00 UTC by Jan ONDREJ
Modified: 2011-04-06 22:52 UTC (History)
6 users (show)

Fixed In Version: clamav-0.97-12.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-06 22:52:53 UTC


Attachments (Terms of Use)

Description Jan ONDREJ 2011-03-30 08:00:48 UTC
Description of problem:
I am getting repeated errors from cron about freshclam.

Version-Release number of selected component (if applicable):
clamav-db-0.97-11.el5
clamav-0.97-11.el5

How reproducible:
Daily.

Steps to Reproduce:
1. rm -f /var/lib/clamav/bytecode.cvd
2. /etc/cron.daily/freshclam
  
Actual results:
ERROR: NotifyClamd: Can't find or parse configuration file /etc/clamd.conf

Expected results:
[empty output]

Additional info:
I don't use clamd. I use sagator, which can use libclam.so directly and does not need clamd running.

Even if I create /etc/clamd.conf, it's still not silent:
ERROR: NotifyClamd: No communication socket specified in /etc/clamd.conf
ERROR: Can't send to clamd: Socket operation on non-socket

I think it's not possible to configure clamd.conf without running clamd to run this quietly.

The freshclam.conf can use NotifyClamd paramter to define clamd configuration file, if it's expected. Why are you forcing this parameter in cron.daily/freshclam script?

Comment 1 Jan-Frode Myklebust 2011-03-30 10:31:40 UTC
I agree that it's bad to be overriding clamav's default here of not enabling NotifyClamd, and it's hardly ever needed as clamd should notice when it's db has changed. Also the change should be very safe, since the affected files are tagged config(noreplace), meaning that this change woun't silently happen to the admin.

I've fixed this in 0.97-12. Not sure if it's worth pushing this out as an update, or wait until there are more changes..

http://koji.fedoraproject.org/koji/buildinfo?buildID=236711

Comment 2 Jan ONDREJ 2011-03-30 10:46:18 UTC
(In reply to comment #1)
> I agree that it's bad to be overriding clamav's default here of not enabling
> NotifyClamd, and it's hardly ever needed as clamd should notice when it's db
> has changed. Also the change should be very safe, since the affected files are
> tagged config(noreplace), meaning that this change woun't silently happen to
> the admin.

I did this on my server, just all future package updates of cron.daily script will be ignored (saved as rpmnew file). It's good to have this file as config, but it's not a good idea to update it on real systems.

> I've fixed this in 0.97-12. Not sure if it's worth pushing this out as an
> update, or wait until there are more changes..
> 
> http://koji.fedoraproject.org/koji/buildinfo?buildID=236711

Please, put it at least to testing.
Thank you.

Comment 3 Fedora Update System 2011-03-30 10:46:44 UTC
clamav-0.97-12.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/clamav-0.97-12.el6

Comment 4 Fedora Update System 2011-03-30 10:47:38 UTC
clamav-0.97-12.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/clamav-0.97-12.el4

Comment 5 Fedora Update System 2011-03-30 10:48:25 UTC
clamav-0.97-12.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/clamav-0.97-12.el5

Comment 6 Jan-Frode Myklebust 2011-03-30 10:49:13 UTC
Done, now give it some karma :-)

Comment 7 Fedora Update System 2011-03-30 17:33:26 UTC
Package clamav-0.97-12.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing clamav-0.97-12.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/clamav-0.97-12.el5
then log in and leave karma (feedback).

Comment 8 Orion Poplawski 2011-04-01 19:52:32 UTC
Seems fine to comment it out, but still change /path/to/clamd.conf to /etc/clamd.conf.

Comment 9 Fedora Update System 2011-04-06 22:51:58 UTC
clamav-0.97-12.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.