This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 692097 - run directory in root with latest update
run directory in root with latest update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
https://fedorahosted.org/fpc/ticket/75
:
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-03-30 08:30 EDT by Marcela Mašláňová
Modified: 2011-04-01 03:23 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-31 10:29:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2011-03-30 08:30:17 EDT
/run directory was introduced after alpha freeze of Fedora. Wouldn't be better to introduce such change in next release of Fedora? 

The change was introduced by systemd-21. It's violation of FHS (according to fedora-devel discussion) and it should definitely have exception in Packaging Guidelines Process. Usually these changes are discussed with FPC before introducing major change.
Comment 1 Michal Schmidt 2011-03-30 09:13:35 EDT
(In reply to comment #0)
> It's violation of FHS (according to fedora-devel discussion)

Or rather: "according to Ralf Corsepius"
All other responses so far are either in favour of the change or neutral.

For the record, the fedora-devel discussion starts here:
http://lists.fedoraproject.org/pipermail/devel/2011-March/150031.html
Comment 2 Michal Schmidt 2011-03-30 09:29:09 EDT
In any case the directory should not be created by the systemd package. I've filed bug 692124 against the filesystem package requesting it be added there.
Comment 3 Michal Schmidt 2011-03-30 10:11:48 EDT
Filed bug 692137 to make the SELinux policy aware of /run.
Comment 4 Bill Nottingham 2011-03-30 12:16:50 EDT
Given that /dev/.whatever was not covered in packaging guidelines, I'm not sure that's a prerequisite for introduction. One certainly should be written, though.

In many ways, as it's done in F-15, it's almost just 'an implementation detail' of /var/run | /var/lock as tmpfs. But I can see why others may think otherwise.
Comment 5 Harald Hoyer 2011-03-30 15:16:19 EDT
(In reply to comment #0)
> /run directory was introduced after alpha freeze of Fedora. Wouldn't be better
> to introduce such change in next release of Fedora? 
> 
> The change was introduced by systemd-21. It's violation of FHS (according to
> fedora-devel discussion) and it should definitely have exception in Packaging
> Guidelines Process. Usually these changes are discussed with FPC before
> introducing major change.

Marcela? Please? Why?
Comment 6 Marcela Mašláňová 2011-03-31 03:27:01 EDT
Why? Because we have some policies, which should be followed. Personally, I don't care if Fedora have /run or not, but it's quite late in release cycle for these kind of changes. I suppose it's not documented, it won't be in release notes of Fedora, it's not in Packaging Guidelines etc.

This bug should be here for Beta blockers review if all needs are satisfied.
Comment 7 Lennart Poettering 2011-03-31 08:35:29 EDT
(In reply to comment #6)
> Why? Because we have some policies, which should be followed. 

But none of the policies I was aware off do forbid this kind of change. Can you name one?

> Personally, I
> don't care if Fedora have /run or not, but it's quite late in release cycle for
> these kind of changes. 

Why? It's technically a minimal change actually.
Comment 8 Marcela Mašláňová 2011-03-31 08:52:38 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > Why? Because we have some policies, which should be followed. 
> 
> But none of the policies I was aware off do forbid this kind of change. Can you
> name one?
> 
https://fedoraproject.org/wiki/Packaging/Guidelines
hint: looking for FHS. Other contributors do have follow these guidelines.

Other people also have concerns:
https://fedorahosted.org/fpc/ticket/75

> > Personally, I
> > don't care if Fedora have /run or not, but it's quite late in release cycle for
> > these kind of changes. 
> 
> Why? It's technically a minimal change actually.

/me wonder whether tiny change could be related with #692475
Comment 9 Rahul Sundaram 2011-03-31 10:29:46 EDT
The note on FHS is not enough as I have already said so when you brought up this point in the mailing list.  Since packaging committee is already tracking this issue, I don't see a point in tracking it in two different places.  Closing this one.
Comment 10 Tomas Mraz 2011-04-01 03:23:24 EDT
The FPC ticket is here https://fedorahosted.org/fpc/ticket/75

Note You need to log in before you can comment on or make changes to this bug.