Bug 692100 - ElectricFence doesn't support posix_memalign
Summary: ElectricFence doesn't support posix_memalign
Keywords:
Status: CLOSED DUPLICATE of bug 684019
Alias: None
Product: Fedora
Classification: Fedora
Component: ElectricFence
Version: 14
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Petr Machata
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-30 12:37 UTC by Yann Droneaud
Modified: 2015-05-05 01:36 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 603075
Environment:
Last Closed: 2011-03-30 12:45:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Debian BTS 599938 None None None Never

Description Yann Droneaud 2011-03-30 12:37:19 UTC
+++ This bug was initially created as a clone of Bug #603075 +++

With ElectricFence-2.2.2-30.fc14, For program that use posix_memalign(), ElectricFence incorrectly report errors such as:

ElectricFence Aborting: free(7fa424019200): address not from malloc().

In fact ElectricFence doesn't support posix_memalign(), so libc'smalloc() is called for allocation, but efence's free() is called for dellocation.

Bug #603075 has a patch that fix the problem.

Comment 1 Yann Droneaud 2011-03-30 12:43:39 UTC
It seems to be fixed in Fedora Core 15's ElectricFence-2.2.2-32.fc15, see this link

http://lists.fedoraproject.org/pipermail/scm-commits/2011-March/579237.html

Comment 2 Yann Droneaud 2011-03-30 12:45:56 UTC

*** This bug has been marked as a duplicate of bug 684019 ***


Note You need to log in before you can comment on or make changes to this bug.