Bug 692103 - No such file or directory: '.../boot/grub/splash.xpm.gz'
No such file or directory: '.../boot/grub/splash.xpm.gz'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-icon-theme (Show other bugs)
15
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
AcceptedBlocker
: Regression
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-03-30 08:50 EDT by Jan Kratochvil
Modified: 2013-03-05 23:06 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-07 13:51:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2011-03-30 08:50:57 EDT
Description of problem:
After the last update livecd-creator can no longer build anything.

Version-Release number of selected component (if applicable):
livecd-tools-15.6-1.fc15.x86_64

How reproducible:
Always.

Steps to Reproduce:
rm -rf /var/cache/live/*
cat >1.ks <<EOH
%include /usr/share/spin-kickstarts/fedora-live-desktop.ks
%include /usr/share/spin-kickstarts/fedora-live-minimization.ks
EOH
livecd-creator --config=1.ks --cache=/var/cache/live

Actual results:
  Installing: ipw2100-firmware             ################### [1167/1167] 

Removing password for user root.
passwd: Success
Note: Forwarding request to 'systemctl enable NetworkManager.service'.
Traceback (most recent call last):
  File "/usr/bin/livecd-creator", line 187, in <module>
    sys.exit(main())
  File "/usr/bin/livecd-creator", line 171, in main
    creator.configure()
  File "/usr/lib/python2.7/site-packages/imgcreate/creator.py", line 748, in configure
    self._create_bootconfig()
  File "/usr/lib/python2.7/site-packages/imgcreate/live.py", line 213, in _create_bootconfig
    self._configure_bootloader(self.__ensure_isodir())
  File "/usr/lib/python2.7/site-packages/imgcreate/live.py", line 695, in _configure_bootloader
    self._configure_efi_bootloader(isodir)
  File "/usr/lib/python2.7/site-packages/imgcreate/live.py", line 664, in _configure_efi_bootloader
    if not self.__copy_efi_files(isodir):
  File "/usr/lib/python2.7/site-packages/imgcreate/live.py", line 609, in __copy_efi_files
    isodir + "/EFI/boot/splash.xpm.gz")
  File "/usr/lib64/python2.7/shutil.py", line 116, in copy
    copyfile(src, dst)
  File "/usr/lib64/python2.7/shutil.py", line 81, in copyfile
    with open(src, 'rb') as fsrc:
IOError: [Errno 2] No such file or directory: '/var/tmp/imgcreate-ZZWQQW/install_root/boot/grub/splash.xpm.gz'

Expected results:
Built .iso file.

Additional info:
Comment 1 Jan Kratochvil 2011-03-30 09:05:10 EDT
It worked with: livecd-tools-15.5-1.fc15.x86_64
Comment 2 Bruno Wolff III 2011-03-30 09:33:06 EDT
This error shows up in the normal live desktop build in the nightlies as well.
Comment 3 Brian Lane 2011-03-30 09:48:05 EDT
Does it work if you go back to using 15.5?

Please attach your kickstart file.
Comment 4 Jan Kratochvil 2011-03-30 10:03:30 EDT
(In reply to comment #3)
> Does it work if you go back to using 15.5?

I was always building images successfully here before by the same command.
Unless some other Component has caused the regression.

Also it was always using my $http_proxy but it no longer does now, even after the downgrade to 15.5-1, this is an unrelated bug but it seems as a regression of some component.


> Please attach your kickstart file.

It is in the comment #0 `Steps to Reproduce', literally these two lines:
%include /usr/share/spin-kickstarts/fedora-live-desktop.ks
%include /usr/share/spin-kickstarts/fedora-live-minimization.ks
Comment 5 Jan Kratochvil 2011-03-30 10:20:26 EDT
(In reply to comment #3)
> Does it work if you go back to using 15.5?

No, it does not.  The same problem is with:
livecd-tools-15.5-1.fc15.x86_64

I hope you have more experience with the livecd builds to guess which Component broke.  Also it should be reproducible for you with current f15 updates-testing.
Comment 6 Brian Lane 2011-03-30 11:35:33 EDT
This looks similar to bug 690940 which I'm trying to reproduce. Also, there were no changes to livecd-creator between 15.5 and 15.6
Comment 7 Brian Lane 2011-03-30 16:54:27 EDT
The source of this error message is that the kickstarts you are using are not including either of the logo packages (fedora-logos or generic-logos), which are responsible for providing the missing splash.xpm.gz file.

The error could be a bit more useful, so I'll fix that up in the next release of livecd-tools.
Comment 8 Bruno Wolff III 2011-03-30 23:02:41 EDT
The problem seems to be gnome-logos.

rpm -qp --provides /home/fedora/development/15/i386/os/Packages/gnome-logos-2.91.92-2.fc15.noarch.rpm
system-logos = 15.0.0-1.fc15
gnome-logos = 2.91.92-2.fc15

rpm -qlp /home/fedora/development/15/i386/os/Packages/gnome-logos-2.91.92-2.fc15.noarch.rpm
/usr/share/pixmaps/fedora-logo-small.png
/usr/share/pixmaps/fedora-logo-sprite.png
/usr/share/pixmaps/fedora-logo-sprite.svg
/usr/share/pixmaps/fedora-logo.png

As compared to fedora-logos.
rpm -ql fedora-logos
/boot/grub/splash.xpm.gz
/etc/favicon.png
/usr/share/anaconda
/usr/share/anaconda/boot
/usr/share/anaconda/boot/splash.lss
/usr/share/anaconda/boot/syslinux-splash.png
/usr/share/anaconda/boot/syslinux-vesa-splash.jpg
/usr/share/anaconda/pixmaps
/usr/share/anaconda/pixmaps/anaconda_header.png
/usr/share/anaconda/pixmaps/progress_first.png
/usr/share/anaconda/pixmaps/splash.png
/usr/share/doc/fedora-logos-15.0.0
/usr/share/doc/fedora-logos-15.0.0/COPYING
/usr/share/firstboot/themes/fedora-lovelock
/usr/share/firstboot/themes/fedora-lovelock/firstboot-left.png
/usr/share/firstboot/themes/fedora-lovelock/workstation.png
/usr/share/gnome-screensaver/lock-dialog-system.glade
/usr/share/gnome-screensaver/lock-dialog-system.gtkrc
/usr/share/gnome-screensaver/lock-dialog-system.png
/usr/share/icons/Bluecurve
/usr/share/icons/Bluecurve/16x16/apps/gnome-main-menu.png
/usr/share/icons/Bluecurve/16x16/apps/icon-panel-menu.png
/usr/share/icons/Bluecurve/16x16/apps/kmenu.png
/usr/share/icons/Bluecurve/16x16/apps/start-here.png
/usr/share/icons/Bluecurve/22x22/apps/gnome-main-menu.png
/usr/share/icons/Bluecurve/22x22/apps/icon-panel-menu.png
/usr/share/icons/Bluecurve/22x22/apps/kmenu.png
/usr/share/icons/Bluecurve/22x22/apps/start-here.png
/usr/share/icons/Bluecurve/24x24/apps/gnome-main-menu.png
/usr/share/icons/Bluecurve/24x24/apps/icon-panel-menu.png
/usr/share/icons/Bluecurve/24x24/apps/kmenu.png
/usr/share/icons/Bluecurve/24x24/apps/start-here.png
/usr/share/icons/Bluecurve/256x256/apps/gnome-main-menu.png
/usr/share/icons/Bluecurve/256x256/apps/icon-panel-menu.png
/usr/share/icons/Bluecurve/256x256/apps/kmenu.png
/usr/share/icons/Bluecurve/256x256/apps/start-here.png
/usr/share/icons/Bluecurve/32x32/apps/gnome-main-menu.png
/usr/share/icons/Bluecurve/32x32/apps/icon-panel-menu.png
/usr/share/icons/Bluecurve/32x32/apps/kmenu.png
/usr/share/icons/Bluecurve/32x32/apps/start-here.png
/usr/share/icons/Bluecurve/36x36/apps/gnome-main-menu.png
/usr/share/icons/Bluecurve/36x36/apps/icon-panel-menu.png
/usr/share/icons/Bluecurve/36x36/apps/kmenu.png
/usr/share/icons/Bluecurve/36x36/apps/start-here.png
/usr/share/icons/Bluecurve/48x48/apps/gnome-main-menu.png
/usr/share/icons/Bluecurve/48x48/apps/icon-panel-menu.png
/usr/share/icons/Bluecurve/48x48/apps/kmenu.png
/usr/share/icons/Bluecurve/48x48/apps/start-here.png
/usr/share/icons/Bluecurve/96x96/apps/gnome-main-menu.png
/usr/share/icons/Bluecurve/96x96/apps/icon-panel-menu.png
/usr/share/icons/Bluecurve/96x96/apps/kmenu.png
/usr/share/icons/Bluecurve/96x96/apps/start-here.png
/usr/share/icons/Fedora/16x16/places/start-here.png
/usr/share/icons/Fedora/22x22/places/start-here.png
/usr/share/icons/Fedora/24x24/places/start-here.png
/usr/share/icons/Fedora/256x256/places/start-here.png
/usr/share/icons/Fedora/32x32/places/start-here.png
/usr/share/icons/Fedora/36x36/places/start-here.png
/usr/share/icons/Fedora/48x48/apps
/usr/share/icons/Fedora/48x48/apps/anaconda.png
/usr/share/icons/Fedora/48x48/places/start-here.png
/usr/share/icons/Fedora/96x96/places/start-here.png
/usr/share/icons/Fedora/scalable/apps
/usr/share/icons/Fedora/scalable/apps/anaconda.svg
/usr/share/icons/Fedora/scalable/places/start-here.svg
/usr/share/icons/hicolor
/usr/share/icons/hicolor/16x16/apps/fedora-logo-icon.png
/usr/share/icons/hicolor/22x22/apps/fedora-logo-icon.png
/usr/share/icons/hicolor/24x24/apps/fedora-logo-icon.png
/usr/share/icons/hicolor/256x256/apps/fedora-logo-icon.png
/usr/share/icons/hicolor/32x32/apps/fedora-logo-icon.png
/usr/share/icons/hicolor/36x36/apps/fedora-logo-icon.png
/usr/share/icons/hicolor/48x48/apps/fedora-logo-icon.png
/usr/share/icons/hicolor/96x96/apps/fedora-logo-icon.png
/usr/share/icons/hicolor/scalable/apps/start-here.svg
/usr/share/icons/hicolor/scalable/apps/xfce4_xicon1.svg
/usr/share/icons/oxygen
/usr/share/icons/oxygen/16x16
/usr/share/icons/oxygen/16x16/places
/usr/share/icons/oxygen/16x16/places/start-here-kde-fedora.png
/usr/share/icons/oxygen/22x22
/usr/share/icons/oxygen/22x22/places
/usr/share/icons/oxygen/22x22/places/start-here-kde-fedora.png
/usr/share/icons/oxygen/24x24
/usr/share/icons/oxygen/24x24/places
/usr/share/icons/oxygen/24x24/places/start-here-kde-fedora.png
/usr/share/icons/oxygen/256x256
/usr/share/icons/oxygen/256x256/places
/usr/share/icons/oxygen/256x256/places/start-here-kde-fedora.png
/usr/share/icons/oxygen/32x32
/usr/share/icons/oxygen/32x32/places
/usr/share/icons/oxygen/32x32/places/start-here-kde-fedora.png
/usr/share/icons/oxygen/36x36
/usr/share/icons/oxygen/36x36/places
/usr/share/icons/oxygen/36x36/places/start-here-kde-fedora.png
/usr/share/icons/oxygen/48x48
/usr/share/icons/oxygen/48x48/apps
/usr/share/icons/oxygen/48x48/apps/anaconda.png
/usr/share/icons/oxygen/48x48/places
/usr/share/icons/oxygen/48x48/places/start-here-kde-fedora.png
/usr/share/icons/oxygen/96x96
/usr/share/icons/oxygen/96x96/places
/usr/share/icons/oxygen/96x96/places/start-here-kde-fedora.png
/usr/share/icons/oxygen/scalable
/usr/share/icons/oxygen/scalable/apps
/usr/share/icons/oxygen/scalable/apps/anaconda.svg
/usr/share/kde4/apps
/usr/share/kde4/apps/ksplash
/usr/share/kde4/apps/ksplash/Themes
/usr/share/kde4/apps/ksplash/Themes/Leonidas/2048x1536/logo.png
/usr/share/pixmaps/bootloader
/usr/share/pixmaps/bootloader/fedora.icns
/usr/share/pixmaps/fedora-logo-small.png
/usr/share/pixmaps/fedora-logo-sprite.png
/usr/share/pixmaps/fedora-logo-sprite.svg
/usr/share/pixmaps/fedora-logo.png
/usr/share/pixmaps/poweredby.png
/usr/share/pixmaps/splash
/usr/share/pixmaps/splash/gnome-splash.png
/usr/share/pixmaps/system-logo-white.png
/usr/share/plymouth/themes/charge
/usr/share/plymouth/themes/charge/progress-00.png
/usr/share/plymouth/themes/charge/progress-01.png
/usr/share/plymouth/themes/charge/progress-02.png
/usr/share/plymouth/themes/charge/progress-03.png
/usr/share/plymouth/themes/charge/progress-04.png
/usr/share/plymouth/themes/charge/progress-05.png
/usr/share/plymouth/themes/charge/progress-06.png
/usr/share/plymouth/themes/charge/progress-07.png
/usr/share/plymouth/themes/charge/progress-08.png
/usr/share/plymouth/themes/charge/progress-09.png
/usr/share/plymouth/themes/charge/progress-10.png
/usr/share/plymouth/themes/charge/progress-11.png
/usr/share/plymouth/themes/charge/progress-12.png
/usr/share/plymouth/themes/charge/progress-13.png
/usr/share/plymouth/themes/charge/progress-14.png
/usr/share/plymouth/themes/charge/progress-15.png
/usr/share/plymouth/themes/charge/progress-16.png
/usr/share/plymouth/themes/charge/progress-17.png
/usr/share/plymouth/themes/charge/progress-18.png
/usr/share/plymouth/themes/charge/throbber-00.png
/usr/share/plymouth/themes/charge/throbber-01.png
/usr/share/plymouth/themes/charge/throbber-02.png
/usr/share/plymouth/themes/charge/throbber-03.png
/usr/share/plymouth/themes/charge/throbber-04.png
/usr/share/plymouth/themes/charge/throbber-05.png
/usr/share/plymouth/themes/charge/throbber-06.png
/usr/share/plymouth/themes/charge/throbber-07.png
/usr/share/plymouth/themes/charge/throbber-08.png
/usr/share/plymouth/themes/charge/throbber-09.png
/usr/share/plymouth/themes/charge/throbber-10.png
/usr/share/plymouth/themes/charge/throbber-11.png
/usr/share/plymouth/themes/charge/throbber-12.png
/usr/share/plymouth/themes/charge/throbber-13.png
/usr/share/plymouth/themes/charge/throbber-14.png
/usr/share/plymouth/themes/charge/throbber-15.png

So gnome-logos should not claim to be providing system-logos when it really isn't.
Comment 9 Bruno Wolff III 2011-03-31 08:18:09 EDT
gnome-logos has been dropped in gnome-icon-theme-2.91.93-1.fc15 which is now in testing.
Comment 10 Bruno Wolff III 2011-03-31 11:53:08 EDT
I tried a build with updates-testing enabled and things seem to be working OK now.
Comment 11 Adam Williamson 2011-03-31 12:45:32 EDT
sorry you've been duplicating this, dennis and I already sorted it out with matthias a couple of nights back but didn't check for a bug report on it.
Comment 12 Jan Kratochvil 2011-03-31 15:53:00 EDT
Confirming it builds now, thanks.
(It does not boot but that would be a different Bug.)
Comment 13 Tim Flink 2011-04-01 13:46:25 EDT
Discussed at the 2011-04-01 blocker bug review meeting. Accepted as F15 beta blocker.
Comment 14 Tim Flink 2011-04-01 16:18:17 EDT
(In reply to comment #13)
> Discussed at the 2011-04-01 blocker bug review meeting. Accepted as F15 beta
> blocker.

Hits the alpha release criteria:

There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (CD/DVD) install.

Fix has been pushed to updates, need testing to verify.
Comment 15 Adam Williamson 2011-04-07 13:51:32 EDT
The update was pushed stable and resolves this, closing.

Note You need to log in before you can comment on or make changes to this bug.