Bug 69213 - Text install: <0>Kernel panic: Attempted to kill init!
Text install: <0>Kernel panic: Attempted to kill init!
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2002-07-18 20:56 EDT by soldier_bob
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:39:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description soldier_bob 2002-07-18 20:56:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
Process swapper (pid: 1, stackpage=c1b79000)
Stack: 09000000 00000000 00000000 00000000 00000000 00000002 00000000 f7c54290
       f7457640 00000000 c0240900 c01387b5 f7c54290 00000001 f7c54290 c0139240
       f7c54290 f738dc00 f7c54290 c024fe44 c0137ae6 f7c54290 00000002 00000001
Call Trace: [<c01387b5>]

Code: 66 39 43 0c 8b 7b 20 0f 85 9c 00 00 00 8b 4b 30 85 c9 0f 84
 <0>Kernel panic: Attempted to kill init!

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot:   text
2. [ok]
3. English [ok] 
4. us [ok]
5. Microsoft - IntelliMouse (PS/2)  -do not check emulate 3 button [ok]
6. Server [ok]	
7. [Autopartition]
8. Remove all pertitions on this system   [*]hda   [ok]
9. verify ok to remove all partitions (all data) on the following drives
10. /dev/hda
 /dev/hda1       1    6      47M  ext3  /boot
 /dev/hda2       7  3021  23650M  ext3  /usr
 /dev/hda3    3022  3275   1992M  swap  
 /dev/hda4    3276  4865  12472M  Extended
   /dev/hda5  3276  4783  11829M  ext3  /home
   /dev/hda6  4784  4832    384M  ext3  /
   /dev/hda7  4833  4865    258M  ext3  /var
11. (*) Use GRUB Boot Loader  [ok]
12. Boot Loader Configuration
/dev/hda   Master Boot record (MBR)
13. Boot Loader Configuration
Enter the boot options-
  **Enter nothing in the fields**
14. Boot Loader Configuration
 boot other OS ?
  **Enter nothing in the fields**
15. GRUB password - none used
16. Firewall Configuration 
17. [*] English (USA)   [ok]
18. America/New_York   [ok]
19.  I entered a password 
20. Add User
**Enter nothing in the fields**   
21. Reading,  reading package information
22. Package Group Selection
[*] Classic X Window System
[*] Gnome
[*] Web Server
33. Video Card Configuration
S3 Trio64V (generic)  
1024 RAM
44. S3 Trio64V+ (generic) [ok]
45. [ok]
46. Installation to begin
log file should be stored /root/install.log
47. formatting  ....  /home /usr /var ....
48. Copying file  (transferring install image to hard drive)
49. ?
50. ERRORS!!!!!

Actual Results:  ..
recieved signal 11 
disabling swap..
unmounting filesystems....
/mnt/runtime done
disabling /dev/loop0
/proc/bus/usb done
/proc done
/dev/pts done
/mnt/source done
/mnt/sysimage/boot done
/mnt/sysimage/dev/pts done
/mnt/sysimage/home done
/mnt/sysimage/proc done
/mnt/sysimage/usr done
/mnt/sysimage/var done
/mnt/sysimage done
ejecting /tmp/cdrom.....
you may safely reboot your system....


** Stalls at Boot from ATAPI CD-ROM **

BIOS is set to start up from floppy, then CDROM, then HDD-0

NOTE:  the messages above were offset by 1 row, so it made a stair effect.  
Also this isnt what happened the time when I got the <0>Kernel panic: Attempted 
to kill init! message.  

Expected Results:  It should have installed.

Additional info:

What a pain this is.  I would devote some time to brainstorming a digital way 
to capture a BSOD dump.  It took a sum of 10 minuets to copy that....

It was also crashing on the normal install same place and the lowres install 
same place.  But I could not get any info from that.  I ran the  'linux 
mediacheck'  on all 3 cd's and all passed.

I also looked for this problem in the bug database bugzilla, but I am not sure 
if I found anything truly similar.

My computer spec:
AMD XP 1800+ (standard fan)
Abit KR7A-133 MB (non-raid)
1024GB DDR
S3 Virge V+ 1mb PCI graphics
HP 1.44 mb Floppy
HANA 14" monitor VGA
Dell Quietkey 101 keyboard
MS Intellimouse (scroll wheel)

I was planning on using RedHat for my business, but from things like this I am 
not sure I want to.  It doesnt seem you are any better off then windows.  I am 
not in the habbit of paying for anything that doesnt function properly.

-Soldier Bob
Comment 1 soldier_bob 2002-07-18 21:01:17 EDT
The GUI versions will crash on "Transferring install image to hard drive"
without fail every time for sever install.  Seems independant of what I am 

I did get the install to tell it worked with the workstation using the GUI 
install.  But then on reboot, it stalls on looking for a boot disk.  It doesnt 
see anything??

Do I need to set the boot to run from a different disk?  
I burned the CD's on a Sony 24x burner... using KODAK GOLD cd's, but I have not 
problems with ANY cd I have ever burned. 

Both my main computer and server are new as of 4 months.

-S. Bob
Comment 2 Michael Fulbright 2002-07-19 14:52:36 EDT
Transfering to kernel component.
Comment 3 Bugzilla owner 2004-09-30 11:39:46 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.