Bug 692179 - System does not suspend when kernel running in Xen Dom0
System does not suspend when kernel running in Xen Dom0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-30 12:02 EDT by W. Michael Petullo
Modified: 2013-09-09 10:09 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-05 15:51:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2011-03-30 12:02:13 EDT
Description of problem:
Power management does not seem to work when the kernel is running in Xen Dom0. For example, "pm-suspend" does not suspend my system. Instead, the system merely becomes unresponsive.

The kernel also does not power down my system when I run shutdown. The last things that is printed to the console is:

Halting system...
[7962.081194] Power down.
-

The system "halts" but does not power down.

Version-Release number of selected component (if applicable):
kernel-2.6.38-1.fc15.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Boot kernel in Xen Dom0
2. Attempt to run "pm-suspend"
3. Reboot and attempt to shutdown
  
Actual results:
System hangs

Expected results:
System should suspend or power off

Additional info:
Comment 1 Konrad Rzeszutek Wilk 2011-09-16 09:01:39 EDT
Patches posted: http://comments.gmane.org/gmane.linux.acpi.devel/50701

but need some work before they are going to be accepted upstream.
Comment 2 Konrad Rzeszutek Wilk 2011-09-29 17:03:39 EDT
Patches posted (v2) https://lkml.org/lkml/2011/9/29/408

the Tboot maintainer acked them.
Comment 3 Josh Boyer 2011-10-11 16:41:05 EDT
These are still working towards inclusion for the 3.2 release.  I don't see us backporting them to F15 at this time.  I'm going to move this bug to rawhide, where we'll see them show up naturally when it gets rebased.

Konrad, if you have an alternative suggestion please let me know.
Comment 4 Josh Boyer 2012-02-22 10:56:42 EST
I believe we're on v4 now, but still not included in linux-next or Linus' tree:

http://thread.gmane.org/gmane.linux.power-management.general/26466
Comment 5 Konrad Rzeszutek Wilk 2012-03-23 17:02:38 EDT
Yeah, some patches for the support are trickling in.
Comment 6 Fedora End Of Life 2013-04-03 11:36:16 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 7 Konrad Rzeszutek Wilk 2013-09-09 10:09:43 EDT
And just in case folks are curious - the patches are in v3.11.

Note You need to log in before you can comment on or make changes to this bug.