Bug 692224 - The image creation process puts the first partition on sector 1 instead of cylinder 1
The image creation process puts the first partition on sector 1 instead of cy...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.1
All Linux
high Severity high
: rc
: ---
Assigned To: Jay Greguske
Release Test Team
: EC2
Depends On: 688652
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-30 14:14 EDT by Jay Greguske
Modified: 2011-05-19 08:57 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 688652
Environment:
Last Closed: 2011-05-19 08:57:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 RHEL Product and Program Management 2011-03-30 14:17:43 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 7 Jay Greguske 2011-04-26 12:08:06 EDT
I've been able to resize in EC2 using this build of appliance-tools, so I think it is resolved. Pierre can you comment on this?
Comment 8 Jay Greguske 2011-05-06 09:46:52 EDT
EC2 images these days are now partition images (#700594), so this bug is no longer relevant in EC2. And since we don't ship appliance-tools to customers, it's really just an internal issue now. 

The test I used to was to boot an image produced by appliance tools (such as one in a compose in /mnt/redhat/rel-eng/RHEL-6.1-RC-1.0/6.1/Appliance) with a larger volume than the partition table allocates for, and then repartition to take up the rest of the space via fdisk. After writing the partition table, reboot the VM. If it comes up without a problem, then I think the bug is fixed.
Comment 9 errata-xmlrpc 2011-05-19 08:57:44 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0540.html

Note You need to log in before you can comment on or make changes to this bug.