This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 692242 - dbus messages don't get back to compliance icon
dbus messages don't get back to compliance icon
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Chris Duryee
John Sefler
:
Depends On:
Blocks: rhsm-rhel62 693528 748554
  Show dependency treegraph
 
Reported: 2011-03-30 15:10 EDT by Chris Duryee
Modified: 2011-12-06 12:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary.
Story Points: ---
Clone Of:
: 693528 (view as bug list)
Environment:
Last Closed: 2011-12-06 12:13:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Duryee 2011-03-30 15:10:42 EDT
Description of problem:

rhsm-compliance-icon is not receiving messages fired by rhsm_complianced.

How to reproduce:

1. run rhsm-compliance-icon -d
2. run /usr/libexec/rhsm_complianced -k -d

What should happen:

You see a signal get fired via the debug message on rhsm_complianced, and then you see a "signal received" message on rhsm-compliance-icon.

What happens:

rhsm_complianced fires the signal, but rhsm-compliance-icon doesn't see it.

Note, this started happening after the rhel5 backporting work.
Comment 2 RHEL Product and Program Management 2011-04-03 22:16:09 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2011-04-04 08:13:40 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 7 Adrian Likins 2011-04-05 14:58:23 EDT
This seems to be working now with rpms from git from master.
Comment 11 John Sefler 2011-07-12 17:37:54 EDT
[root@jsefler-onprem-62server product]# rpm -q subscription-manager
subscription-manager-0.96.3-1.git.33.8f93d7f.el6.x86_64

Adrian,
In my attempt to verify this bug on rhel62, I am following these verification steps from rhel57 https://bugzilla.redhat.com/show_bug.cgi?id=693528#c2   Unfortunately there is no output from step 4. run # rhsm-icon -d and the icon does not display.
Comment 12 Chris Duryee 2011-08-08 15:17:58 EDT
John,

I ran into the same issue. It turns out you need "rhsm-icon -i -d". The -i makes a check happen immediately, and not after X minutes (see 700547 for more detail).

Marking as MODIFIED.
Comment 14 J.C. Molet 2011-08-22 15:40:33 EDT
(In reply to comment #12)
> John,
> 
> I ran into the same issue. It turns out you need "rhsm-icon -i -d". The -i
> makes a check happen immediately, and not after X minutes (see 700547 for more
> detail).
> 
> Marking as MODIFIED.

Not exactly sure what I'm looking for here,  I start the dbus-monitor and then run "rhsm-icon -i -d" and get a lot of dbus message about product checking, then when I run the rhsmd, I get no messages whatsoever over dbus (or any debug messages).  Is this expected if no changes are detected?
Comment 15 Chris Duryee 2011-09-06 10:52:41 EDT
Yup, that is correct if no changes are detected.
Comment 16 John Sefler 2011-09-13 16:27:09 EDT
Attempts to verify....
[root@jsefler-onprem-62server product]# rpm -q subscription-manager
subscription-manager-0.96.9-1.git.10.adab5e3.el6.x86_64
[root@jsefler-onprem-62server product]# rpm -q python-rhsm
python-rhsm-0.96.11-1.git.8.7061b8a.el6.noarch

1. I put only the 37060.pem product cert into /etc/pki/product from my
onpremises candlpin server.

2. I killed all rhsm* processes

3. in first terminal, run # /usr/libexec/rhsmd -k -d

^^^ note no output yet in first terminal

4. in second terminal, run # rhsm-icon -d -i
** (rhsm-icon:12231): DEBUG: Running entitlement status check
** (rhsm-icon:12231): DEBUG: in callback, received value: 1
** (rhsm-icon:12231): DEBUG: Icon already visible

^^^ VERIFIED this output in second terminal and the icon displays

System has one or more certificates that are not valid
['37060']
[]
Validity status changed, fire signal
signal fired! code is 1

^^^ also VERIFIED this output in first terminal

5. in third terminal, run
[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1 --password=password --org=admin
The system has been registered with id: 6a8d3910-1334-4543-b5f8-cc34a67c88b3 
[root@jsefler-onprem-62server ~]# subscription-manager subscribe --pool=8a90f8c6325fd85c01325fd9fccb02c9
Successfully subscribed the system to Pool 8a90f8c6325fd85c01325fd9fccb02c9
[root@jsefler-onprem-62server ~]# 


^^^ VERIFIED icon goes away

System entitlements appear valid
Validity status changed, fire signal
signal fired! code is 0

^^^ VERIFIED this output in first terminal

** (rhsm-icon:122231): DEBUG: in callback, received value: 0

^^^ VERIFIED this output in second terminal


6. in third terminal, run
[root@jsefler-onprem-62server ~]# subscription-manager unsubscribe --all

^^^ FAILED TO VERIFY icon returns

System has one or more certificates that are not valid
['37060']
[]
Validity status changed, fire signal
signal fired! code is 1

^^^ VERIFIED this output in first terminal

** (rhsm-icon:12231): DEBUG: in callback, received value: 1

(rhsm-icon:12231): Gtk-CRITICAL **: gtk_status_icon_set_tooltip_text: assertion `GTK_IS_STATUS_ICON (status_icon)' failed

(rhsm-icon:12231): GLib-GObject-WARNING **: instance of invalid non-instantiatable type `(null)'

(rhsm-icon:12231): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(rhsm-icon:12231): GLib-GObject-WARNING **: instance of invalid non-instantiatable type `(null)'

(rhsm-icon:12231): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(rhsm-icon:12231): libnotify-CRITICAL **: notify_notification_new_with_status_icon: assertion `GTK_IS_STATUS_ICON (status_icon)' failed

(rhsm-icon:12231): libnotify-CRITICAL **: notify_notification_add_action: assertion `notification != NULL' failed

(rhsm-icon:12231): libnotify-CRITICAL **: notify_notification_add_action: assertion `notification != NULL' failed

(rhsm-icon:12231): Gtk-CRITICAL **: gtk_status_icon_set_visible: assertion `GTK_IS_STATUS_ICON (status_icon)' failed

(rhsm-icon:12231): GLib-GObject-WARNING **: instance of invalid non-instantiatable type `(null)'

(rhsm-icon:12231): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

^^^ FAILED OUTPUT in second terminal



DBUS messages are now being sent by rhsmd and received by the rhsm-icon, but the verification steps failed to re-display the rhsm-icon upon unsubscribing.  Expected the rhsm-icon to re-display.

moving back to NEW/FailedQA
Comment 17 Chris Duryee 2011-09-23 13:20:06 EDT
0950ea6 master 0.97.2+
00f082  RHEL6.2 0.96.12+
Comment 18 John Sefler 2011-10-14 16:04:25 EDT
Attempt to Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.14-1.git.3.b926c9e.el6.x86_64
[root@jsefler-onprem-62server ~]# rpm -q python-rhsm
python-rhsm-0.96.13-1.git.0.a237980.el6.noarch

While re-testing the steps in comment 16, the "VERIFIED icon goes away" assertion in step 5 failed.

In otherwords, using the subscription-manager cli to subscribe coverage for all the installed products (one in this case), the rhsm-icon failed to disappear from the desktop tray at the instant the system.entitlements_valid fact turned True.

regretfully moving back to NEW/FailedQA
Comment 19 Chris Duryee 2011-10-18 14:02:07 EDT
54f2689 master 0.97.2+
5cf46f4 RHEL6.2 0.96.16+
Comment 20 J.C. Molet 2011-10-18 16:01:48 EDT
1. Testing with 1000000000008.pem

2. killall rhsm processes

3. in terminal 1: [root@jmolet-vm0 ~]# /usr/libexec/rhsmd -k -d

  ====== no output yet ======
  
4. in terminal 2: [root@jmolet-vm0 ~]# rhsm-icon -d -i
** (rhsm-icon:1278): DEBUG: Running entitlement status check
** (rhsm-icon:1278): DEBUG: in callback, received value: 1
** (rhsm-icon:1278): DEBUG: Icon already visible

^^^ VERIFIED icon becomes visible ^^^^

System has one or more certificates that are not valid
['100000000000008']
[]
Validity status changed, fire signal
signal fired! code is 1

^^^ VERIFIED in terminal 1 when icon appears ^^^

5. In terminal 3:
[root@jmolet-vm0 ~]# subscription-manager register --user testuser1 --pass password --org admin
The system has been registered with id: c928e2fd-e338-4aec-b0b8-65c7cbbe511f 
[root@jmolet-vm0 ~]# subscription-manager subscribe --auto
Installed Product Current Status:

ProductName:            Awesome OS for x86_64/s390x Bits
Status:                 Subscribed               

[root@jmolet-vm0 ~]# subscription-manager facts --list | grep valid
system.entitlements_valid: True

Terminal 1:
System has one or more certificates that are not valid
['100000000000008']
[]
System entitlements appear valid
Validity status changed, fire signal
signal fired! code is 0

Terminal 2: 
** (rhsm-icon:1704): DEBUG: in callback, received value: 0

^^^ VERIFIED signal was recieved and icon dissapears ^^^

6. Terminal 3:
subscription-manager unsubscribe --all

Terminal 1:
System has one or more certificates that are not valid
['100000000000008']
[]
Validity status changed, fire signal
signal fired! code is 1

Terminal 2:
** (rhsm-icon:1704): DEBUG: in callback, received value: 1

^^^ VERIFIED signal is recieved and icon reappears ^^^



All tests pass.  Marking VERIFIED:

subscription-manager-firstboot-0.96.15-1.git.9.0e69b12.el6.x86_64
subscription-manager-gnome-0.96.15-1.git.9.0e69b12.el6.x86_64
python-rhsm-0.96.13-1.git.1.15c6c49.el6.noarch
subscription-manager-0.96.15-1.git.9.0e69b12.el6.x86_64
Comment 21 Bryan Kearney 2011-11-14 12:43:45 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary.
Comment 22 errata-xmlrpc 2011-12-06 12:13:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.